Bug 1657013

Summary: Konsole Crashes When Logging Out All Tabs in a Window Using "Copy Input To" Feature
Product: [Fedora] Fedora Reporter: Jeremy Petersen <jeremy.g.petersen>
Component: konsole5Assignee: Rex Dieter <rdieter>
Status: CLOSED ERRATA QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: high Docs Contact:
Priority: unspecified    
Version: 29CC: rdieter
Target Milestone: ---   
Target Release: ---   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: konsole5-18.12.3-2.fc30 konsole5-18.12.3-2.fc29 Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2019-04-15 00:02:24 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Attachments:
Description Flags
Backtrace details from the Dr Konqi bug report.
none
Updated Backtrace Containing Full Debug Info none

Description Jeremy Petersen 2018-12-06 20:21:07 UTC
Created attachment 1512269 [details]
Backtrace details from the Dr Konqi bug report.

Description of problem:
Konsole crashes and closes unexpectedly when logging out of multiple tabs at once using the Copy Input To -> All Tabs in Current Window feature. Many times this crash will affect other (completely separate) Konsole windows, causing unexpected loss of active sessions and work in many cases.

Version-Release number of selected component (if applicable):
This issue happens consistently on both FC28 and FC29 (running on VirtualBox 5.2.x). The last Fedora release that I know did not exhibit this behavior (so, known good) was Fedora 26 - I cannot vouch for whether FC27 also had this issue or not.


How reproducible:
Happens nearly every time the following steps are performed.


Steps to Reproduce:
1. Open Konsole window
2. Open multiple tabs within that Konsole window
3. Select Edit menu -> Copy Input To -> All Tabs in Current Window
4. Type a ctrl-D to issue logout command to all tabs in window


Actual results:
Konsole completely crashes with a (Dr Konqi) bug report popup in the system tray area. 

Details of the bug are: Executable: kdeinit5 PID: 3171 Signal: Segmentation fault (11) Time: 12/6/18 12:03:54

Backtrace document is attached below.


Expected results:
Expected results for the above steps would be for that paritcular Konsole window to close out gracefully, not producing a bug report, and not bringing down any neighboring Konsole windows.


Additional info:
FYI... If I turn off the Copy Input To feature and simply ctrl-D out of each tab individually then this issue does not occur. Also, if you restrict the Copy Input To feature to only a subset of the tabs in that window (even if leaving only one not included) then this issue does not present. The only time this seems to happen is when using ctrl-D to logout of ALL tabs in a Konsole window, all at once, so that the window in question is expected to completely close as a result. 

This bug has not been filed with the KDE team, as I do not have a user account there, nor do I want to create one.

Comment 1 Jeremy Petersen 2018-12-06 21:24:15 UTC
Created attachment 1512294 [details]
Updated Backtrace Containing Full Debug Info

I have installed the necessary debuginfo packages and rengenerated the backtrace. The new attachment should contain full debug info.

Comment 2 Rex Dieter 2018-12-06 22:53:27 UTC
If you're genuinely interested in getting this fixed, reporting it upstream is the best way to achieve that.

Otherwise, I (or any other maintainer) can do it on your behalf, as time/priority allows.

Comment 3 Jeremy Petersen 2018-12-10 16:20:40 UTC
Understood. I will reply back if I find the time to do so. I am surprised nobody else has reported it actually, at least that I could find. 

Any chance you (or someone) could at least confirm the bug for me, so I know I'm not just going crazy?

Comment 4 Jeremy Petersen 2019-03-06 23:09:49 UTC
Hi, FYI... Bug 405158 (https://bugs.kde.org/show_bug.cgi?id=405158) has been opened with the KDE team on this.

Here is an updated steps to reproduce, copied from the KDE bug report. There appears to be a critical piece that I missed before (step 3 in this updated list) that prevents this issue from presenting if missed.

Steps to Reproduce:
1. Open Konsole window
2. Open multiple tabs within that Konsole window
3. (apparently an important piece) Scroll through the tabs and go back to the first one opened, on the far left of the tab bar
4. Select Edit menu -> Copy Input To -> All Tabs in Current Window
5. Type a ctrl-D to issue logout command to all tabs in window

It is at this point that the crash occurs, displaying the popup near the system tray, and, as mentioned above, this crash will often times cause other neighboring konsole windows to crash as well. It is seeminly inconsistent though, sometimes not affecting all other nearby windows, and not sometimes affecting no others. 


- Unusual behavior I noticed:

Interestingly, it seems that if you skip step 3 above and leave the active tab as the last one opened, and then make that last tab the one copying input to all tabs in current window, instead of the first, then the issue does not present itself. However, for me, after navigating back to the first tab opened (as in step 3) and making that first tab the master copying to all tabs in window, then the issue presents very consistently, with seemingly every try.

Comment 5 Jeremy Petersen 2019-03-18 15:45:52 UTC
Hi, the KDE team has produced a fix for this issue under the bug mentioned in my previous post. 

Rex, can you provide any estimate when this fix might make it down to Fedora for testing/inclusion in FC29?

Comment 6 Rex Dieter 2019-03-18 18:48:32 UTC
worst case, when kde makes their next release that includes the fix.

best case and good news, the fix appears small and easily back-portable (given fedora maintainer time/availability, of course),
https://cgit.kde.org/konsole.git/commit/?id=cb49c985a31692806be5f8f717d79b1425cfcbc9

As for time, mine will be limited in the short-term, due to @dayjob and working on f30-beta/releases

Comment 7 Jeremy Petersen 2019-04-11 15:51:07 UTC
Hi Rex, can you tell me which version of konsole is currently included in f30? I do not have time to test out the f30 beta at the moment.

Comment 8 Rex Dieter 2019-04-11 15:55:41 UTC
Both f29/f30 ship konsole 18.12.2 currently

Comment 9 Rex Dieter 2019-04-11 16:10:04 UTC
Thanks for the poke (by the way), found a few minutes to pull in the upstream fix and submit patched builds.

Comment 10 Jeremy Petersen 2019-04-11 16:13:51 UTC
That's great. Thanks!

Comment 11 Fedora Update System 2019-04-11 16:18:30 UTC
konsole5-18.12.3-2.fc30 has been submitted as an update to Fedora 30. https://bodhi.fedoraproject.org/updates/FEDORA-2019-aa236ae27e

Comment 12 Fedora Update System 2019-04-11 16:19:10 UTC
konsole5-18.12.3-2.fc29 has been submitted as an update to Fedora 29. https://bodhi.fedoraproject.org/updates/FEDORA-2019-3eb498ff52

Comment 13 Fedora Update System 2019-04-13 01:59:47 UTC
konsole5-18.12.3-2.fc30 has been pushed to the Fedora 30 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2019-aa236ae27e

Comment 14 Fedora Update System 2019-04-13 12:10:28 UTC
konsole5-18.12.3-2.fc29 has been pushed to the Fedora 29 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2019-3eb498ff52

Comment 15 Fedora Update System 2019-04-15 00:02:24 UTC
konsole5-18.12.3-2.fc30 has been pushed to the Fedora 30 stable repository. If problems still persist, please make note of it in this bug report.

Comment 16 Fedora Update System 2019-04-22 05:09:46 UTC
konsole5-18.12.3-2.fc29 has been pushed to the Fedora 29 stable repository. If problems still persist, please make note of it in this bug report.