Bug 1657027

Summary: jenkins flake in e2e-gcp-builds
Product: OpenShift Container Platform Reporter: Gabe Montero <gmontero>
Component: ImageStreamsAssignee: Gabe Montero <gmontero>
Status: CLOSED ERRATA QA Contact: XiuJuan Wang <xiuwang>
Severity: medium Docs Contact:
Priority: unspecified    
Version: 4.1.0CC: aos-bugs, jokerman, mmccomas, wzheng
Target Milestone: ---   
Target Release: 4.1.0   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Cause: Jenkins pipeline swapping can lead temporary flownode unavailability Consequence: OpenShift Jenkins Pipeline jobs could intermittently fail with an IOException Fix: The openshift sync plugin will catch such and exception and attempt to retry flownode access Result: We should be tolerant of the momentary unavailability to flownodes which are possible with Jenkins Pipelines.
Story Points: ---
Clone Of: Environment:
Last Closed: 2019-06-04 10:41:14 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Comment 2 Gabe Montero 2018-12-14 15:58:34 UTC
PR https://github.com/openshift/jenkins/pull/762 is updating the image

PR e2e testing and e2e-gcp should be sufficient verification for this change.
Will move directly to verify when those tests pass.

Comment 5 errata-xmlrpc 2019-06-04 10:41:14 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2019:0758