Bug 1657854

Summary: remove userland support for deprecated KLIPS IPsec stack support
Product: Red Hat Enterprise Linux 8 Reporter: Paul Wouters <pwouters>
Component: libreswanAssignee: Paul Wouters <pwouters>
Status: CLOSED CURRENTRELEASE QA Contact: Jaroslav Aster <jaster>
Severity: medium Docs Contact: Ioanna Gkioka <igkioka>
Priority: medium    
Version: ---CC: igkioka, jaster
Target Milestone: rcFlags: igkioka: needinfo? (pwouters)
Target Release: 8.0   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: 3.27-4 Doc Type: Removed functionality
Doc Text:
.KLIPS has been removed from *Libreswan* In Red Hat Enterprise Linux 8, support for Kernel IP Security (KLIPS) IPsec stack has been removed from *Libreswan*.
Story Points: ---
Clone Of: Environment:
Last Closed: 2019-06-14 01:45:09 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description Paul Wouters 2018-12-10 15:34:53 UTC
upstream libreswan supports an alternative KLIPS IPsec stack. This stack was never supported in RHEL. But userland was built with support for this stack so customer who wanted to use the alternative IPsec kernel stack could do so without recompiling the libreswan userland.

Upstream is disabling KLIPS support per default and will remove it entirely soon.

Therefor, remove the userland support from libreswan in RHEL8. This should affect no regular users of libreswan with RHEL.