Bug 1658193

Summary: Bump ovirt_provision_plugin to 2.0.3
Product: Red Hat Satellite Reporter: Martin Perina <mperina>
Component: PackagingAssignee: satellite6-bugs <satellite6-bugs>
Status: CLOSED ERRATA QA Contact: Lukas Pramuk <lpramuk>
Severity: high Docs Contact:
Priority: unspecified    
Version: 6.4CC: egolov, ehelms, masayag, mgoldboi, mperina
Target Milestone: 6.5.0Keywords: Triaged
Target Release: Unused   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: tfm-rubygem-ovirt_provision_plugin-2.0.3 Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2019-05-14 12:39:33 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description Martin Perina 2018-12-11 13:35:08 UTC
Description of problem:

We are going to release ovirt_provision_plugin 2.0.0, which:

1. Uses RHV APIv4 instead of deprecated APIv3 (which will become unsupported in RHV 4.3)
2. Fixes several issues around "provisioning a host" flow executed from RHV

Could you please include that updated version into Satellite 6.4.z?


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

Comment 3 Moti Asayag 2018-12-11 13:45:22 UTC
* the updated release is ovirt_provision_plugin 2.0.1

Comment 4 Moti Asayag 2018-12-11 22:26:31 UTC
(In reply to Moti Asayag from comment #3)
> * the updated release is ovirt_provision_plugin 2.0.1

The latest version is  ovirt_provision_plugin 2.0.2.

Comment 5 Moti Asayag 2019-01-20 12:04:03 UTC
(In reply to Moti Asayag from comment #4)
> (In reply to Moti Asayag from comment #3)
> > * the updated release is ovirt_provision_plugin 2.0.1
> 
> The latest version is  ovirt_provision_plugin 2.0.2.

Version 2.0.2 had an issue with localization. Please use ovirt_provision_plugin 2.0.3

Comment 6 Lukas Pramuk 2019-02-22 13:05:37 UTC
VERIFIED.

@satellite-6.5.0-6.beta.el7sat.noarch
tfm-rubygem-ovirt_provision_plugin-2.0.3-1.el7sat.noarch

by the following manual reproducer:

0. Have Satellite default installation

1. Check for tfm-rubygem-ovirt_provision_plugin rpm


FIX:

# yum list  tfm-rubygem-ovirt_provision_plugin
Available Packages
tfm-rubygem-ovirt_provision_plugin.noarch        2.0.3-1.el7sat        satellite

vs.

REPRO:

# yum list  tfm-rubygem-ovirt_provision_plugin
Available Packages
tfm-rubygem-ovirt_provision_plugin.noarch        1.0.2-2.el7sat        satellite

Comment 8 errata-xmlrpc 2019-05-14 12:39:33 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHSA-2019:1222