Bug 1658308

Summary: Customer cannot delete versioned bucket
Product: Red Hat Ceph Storage Reporter: Bob Emerson <roemerso>
Component: RGW-MultisiteAssignee: J. Eric Ivancich <ivancich>
Status: CLOSED ERRATA QA Contact: Tejas <tchandra>
Severity: high Docs Contact: John Brier <jbrier>
Priority: high    
Version: 3.1CC: aglotov, bancinco, cbodley, ceph-eng-bugs, ceph-qe-bugs, edonnell, ivancich, mbenjamin, mhackett, mkogan, roemerso, tserlin, vimishra, vumrao
Target Milestone: z1   
Target Release: 3.2   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: RHEL: ceph-12.2.8-67.el7cp Ubuntu: ceph_12.2.8-52redhat1xenial Doc Type: Bug Fix
Doc Text:
.Buckets with false entries can now be deleted as expected Previously, bucket indices could include "false entries" that did not represent actual objects and that resulted from a prior bug. Consequently, during the process of deleting such buckets, encountering a false entry caused the process to stop and return an error code. With this update, when a false entry is encountered, Ceph ignores it, and deleting buckets with false entries works as expected.
Story Points: ---
Clone Of:
: 1690930 (view as bug list) Environment:
Last Closed: 2019-03-07 15:51:12 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Bug Depends On:    
Bug Blocks: 1629656, 1690930    

Comment 73 errata-xmlrpc 2019-03-07 15:51:12 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2019:0475