Bug 1661882

Summary: Nfs-ganesha with rgw config for multi tenancy rgw users
Product: Red Hat Ceph Storage Reporter: Manjunatha <mmanjuna>
Component: RGWAssignee: Matt Benjamin (redhat) <mbenjamin>
Status: CLOSED ERRATA QA Contact: vidushi <vimishra>
Severity: high Docs Contact: John Brier <jbrier>
Priority: high    
Version: 3.1CC: assingh, cbodley, ceph-eng-bugs, edonnell, gsitlani, kbader, kjosy, mbenjamin, mmanjuna, pasik, sweil, tchandra, tonay, tserlin, vumrao
Target Milestone: z1Flags: bancinco: needinfo? (mbenjamin)
Target Release: 3.2   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: RHEL: ceph-12.2.8-64.el7cp Ubuntu: ceph_12.2.8-49redhat1 Doc Type: Bug Fix
Doc Text:
.Mapping NFS exports to Object Gateway tenant user IDs works as expected Previously, the NFS server for the Ceph Object Gateway (`nfs-ganesha`) did not correctly map Object Gateway tenants into their correct namespace. As a consequence, an attempt to map an NFS export onto Ceph Object Gateway with a tenanted user ID silently failed; the account could authenticate and NFS mounts could succeed, but the namespace did not contain buckets and objects. This bug has been fixed, and tenanted mappings are now set correctly. As a result, NFS exports can now be mapped to Object Gateway tenant user IDs and buckets and objects are visible as expected in the described situation.
Story Points: ---
Clone Of: Environment:
Last Closed: 2019-03-07 15:51:12 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Bug Depends On:    
Bug Blocks: 1629656    

Comment 8 Vikhyat Umrao 2019-01-15 18:40:07 UTC
Looks like we have the fix in master we need to backport to downstream https://github.com/ceph/ceph/pull/19358

Comment 35 errata-xmlrpc 2019-03-07 15:51:12 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2019:0475