Bug 1662910

Summary: Realtek Semiconductor Co., Ltd. RTL8111/8168/8411 on FC29 not working with latest kernel
Product: [Fedora] Fedora Reporter: malc996
Component: kernelAssignee: Kernel Maintainer List <kernel-maint>
Status: CLOSED DUPLICATE QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: medium Docs Contact:
Priority: unspecified    
Version: 29CC: airlied, bskeggs, ewk, hdegoede, ichavero, itamar, jarodwilson, jglisse, john.j5live, jonathan, josef, kernel-maint, linville, mchehab, mjg59, steved, yaneti
Target Milestone: ---   
Target Release: ---   
Hardware: x86_64   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2019-01-02 11:33:18 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description malc996 2019-01-02 11:20:03 UTC
Description of problem:
Network card not working after upgrade to FC29

07:00.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller (rev 01)

Latest FC29 kernel as of 2 Jan 2019 (can't get version at the moment having to book old kernel)

Saw the same problem with latest FC28 kernel, hence upgraded to FC29


Version-Release number of selected component (if applicable):


How reproducible:
Boolean, new kernel doesn't work old FC28 (4.18.16-200.x86_64 is OK but later FC28 kernels fail in the same way)

Steps to Reproduce:
1. upgrade from fc28 to fc29
2. test network fails
3. reboot old kernel works

Actual results:
no network

Expected results:
network functioning

Additional info:

Network comes up as "off" in the Network GUI
systemctl start network produced no errors on startup but shows :
 that resolve.conf can't be found although it is there and has correct permissions

Comment 1 Yanko Kaneti 2019-01-02 11:33:18 UTC
Thanks for the report. You could test the kernel from updates-testing which should be addressing the problem.

*** This bug has been marked as a duplicate of bug 1650984 ***