Bug 1667733

Summary: gnome-control-center will not start
Product: [Fedora] Fedora Reporter: pmkellly
Component: gnome-control-centerAssignee: Pete Walter <walter.pete>
Status: CLOSED WORKSFORME QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: unspecified Docs Contact:
Priority: unspecified    
Version: rawhideCC: dbxx, gnome-sig, walter.pete
Target Milestone: ---   
Target Release: ---   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2019-07-16 13:08:15 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description pmkellly 2019-01-20 16:31:01 UTC
Description of problem:
gnome-control-center will not start in Rawhide (F30) Workstation drop 01/17/2018

Version-Release number of selected component (if applicable):
3.31.4-1.fc30.x86-64

How reproducible:
As below:

Steps to Reproduce:
1. Any of these single steps will show the problem
2. Click the Settings icon in the top bar.
3. Click "Settings" in the menu that appears when right clicking on the wall paper.
4. Click the Settings icon in the applications matrix.

Actual results:
After a pause the Oops notification appears in the top bar.

Expected results:
The Settings window should open on the screen.

Additional info:
I tried reinstalling gnome-control-center and the failure persisted.

Abrt does catch the error, but will not report it. The report process runs through "looking for similar problems in bugzilla" and quits with the message "Reporting disabled because the generated backtrace has low information value".

I can still modify gnome keys with gsettings.

Comment 1 pmkellly 2019-01-22 14:06:26 UTC
After installing Rawhide (F30) drop 01/21 I did a restart. After the restart, I starting the gnome-control-center by clicking the Settings icon in the top bar menu. Settings started normally. Then in settings I changed the screen resolution, set the screen timeout to "Never" and closed the settings. Then I opened a terminal and removed the user password (passwd -d) set during the first Gnome start up after the install. Then I added a Root pass word (passwd). I then closed the terminal and did another restart. After the restart I tried starting Settings as described before and got the Oops notification. This time Abrt did report the bug and it was a duplicate.

Comment 2 pmkellly 2019-02-04 13:17:16 UTC
This bug remain present through Rawhide (F30) drop 0203

Comment 3 pmkellly 2019-07-16 13:08:15 UTC
This is working fine now in F30 Released through Rawhide (F31) drop 0711)