Bug 1668883

Summary: Sync downstream patches with 7.6
Product: Red Hat Enterprise Linux 8 Reporter: Florian Müllner <fmuellner>
Component: mutterAssignee: Jonas Ådahl <jadahl>
Status: CLOSED CURRENTRELEASE QA Contact: Desktop QE <desktop-qa-list>
Severity: unspecified Docs Contact: Marie Dolezelova <mdolezel>
Priority: unspecified    
Version: 8.0CC: briang, cschalle, fmuellner, igkioka, jadahl, jkoten, jwboyer, mboisver, mclasen, tpelka
Target Milestone: rc   
Target Release: 8.0   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: mutter-3.28.3-15.el8 Doc Type: Enhancement
Doc Text:
.Fractional scaling available for GNOME Shell on Wayland On a *GNOME Shell on Wayland* session, the fractional scaling feature is available. The feature makes it possible to scale the GUI by fractions, which improves the appearance of scaled GUI on certain displays. Note that the feature is currently considered experimental and is, therefore, disabled by default. To enable fractional scaling, run the following command: # gsettings set org.gnome.mutter experimental-features "['scale-monitor-framebuffer']"
Story Points: ---
Clone Of: Environment:
Last Closed: 2019-06-14 02:04:32 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
Bug Depends On:    
Bug Blocks: 1635157    

Description Florian Müllner 2019-01-23 19:47:11 UTC
Description of problem:

The component was already rebased to the 8.0 GNOME version in RHEL 7. But as RHEL 8 was branched off from the corresponding Fedora version rather than the last RHEL branch, all downstream patches went missing.

As the upstream version hasn't changed since the last RHEL 7 release, fortunately all patches are ready to be re-applied again.

Comment 2 Florian Müllner 2019-01-24 16:26:26 UTC
I was asked to provide a list of patches that went missing:

0001-backends-x11-Support-synaptics-configuration.patch
0001-clutter-Do-not-latch-modifiers-on-modifier-keys.patch
0001-clutter-Extend-touchpad-device-property-check-for-Sy.patch
0001-clutter-Only-reset-scroll-axes-on-slave-devices.patch
0001-clutter-x11-Implement-keycode-lookup-from-keysyms-on.patch
0001-events-Don-t-move-sloppy-focus-while-buttons-are-pre.patch
0001-main-be-more-aggressive-in-assuming-X11-backend.patch
0001-monitor-manager-Consider-external-layout-before-defa.patch
0001-monitor-manager-only-reuse-initial-config-if-monitor.patch
0001-monitor-manager-xrandr-Force-an-update-when-resuming.patch
0001-monitor-manager-xrandr-Work-around-spurious-hotplugs.patch
0001-wayland-enable-scale-monitor-framebuffer-by-default.patch
0001-window-actor-Special-case-shaped-Java-windows.patch
0008-Add-support-for-quad-buffer-stereo.patch
add-support-for-plain-old-x-device-configuration.patch
deal-more-gracefully-with-oversized-windows.patch
fix-crash-when-modal-closes-during-drag.patch

Comment 9 Jonas Ådahl 2019-02-21 14:14:23 UTC
As of 3.28.3-18 the patch 0001-wayland-enable-scale-monitor-framebuffer-by-default.patch was removed, as it was added by accident.

Comment 10 Jonas Ådahl 2019-02-21 14:46:41 UTC
(In reply to Jonas Ådahl from comment #9)
> As of 3.28.3-18 the patch
> 0001-wayland-enable-scale-monitor-framebuffer-by-default.patch was removed,
> as it was added by accident.

To get back the experimental feature enabling fractional scaling, as was enabled in 7.6 (on Wayland only, thus not in the default configuration), one have to run the following command:

gsettings set org.gnome.mutter experimental-features "['scale-monitor-framebuffer']"