Bug 1668924 (CVE-2019-6286)

Summary: CVE-2019-6286 libsass: heap-based buffer over-read in Sass::Prelexer::skip_over_scopes in prelexer.hpp
Product: [Other] Security Response Reporter: Laura Pardo <lpardo>
Component: vulnerabilityAssignee: Red Hat Product Security <security-response-team>
Status: CLOSED NOTABUG QA Contact:
Severity: low Docs Contact:
Priority: low    
Version: unspecifiedCC: aurelien, fmuellner
Target Milestone: ---Keywords: Security
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard: impact=low,public=20190114,reported=20190114,source=cve,cvss3=3.3/CVSS:3.0/AV:L/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:L,cwe=CWE-125,fedora-all/libsass=affected,epel-7/libsass=affected,rhel-8/libsass=notaffected
Fixed In Version: Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2019-02-21 15:10:32 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
Bug Depends On: 1668925, 1668926    
Bug Blocks: 1668927    

Description Laura Pardo 2019-01-23 21:34:12 UTC
In LibSass 3.5.5, a heap-based buffer over-read exists in Sass::Prelexer::skip_over_scopes in prelexer.hpp when called from Sass::Parser::parse_import(), a similar issue to CVE-2018-11693.


References:
https://github.com/sass/libsass/issues/2815

Comment 1 Laura Pardo 2019-01-23 21:34:26 UTC
Created libsass tracking bugs for this issue:

Affects: epel-7 [bug 1668926]
Affects: fedora-all [bug 1668925]