Bug 1671819

Summary: POCL package needs rebuilt using available current clang version
Product: [Fedora] Fedora Reporter: Robert <rr.underwood94>
Component: poclAssignee: Tom Stellard <tstellar>
Status: CLOSED ERRATA QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: unspecified Docs Contact:
Priority: unspecified    
Version: 29CC: besser82, fabian.deutsch, igor.raits, tstellar
Target Milestone: ---   
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: pocl-1.2-1.fc29 Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2019-02-13 02:47:14 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description Robert 2019-02-01 18:35:14 UTC
Description of problem:

Portable Compute Language determines the opencl header location for clang using clang --print-resource-dir at package configure time.  POCL requires a package rebuild when clang's version is bumped since the path contains the version.

Version-Release number of selected component (if applicable):

at least Fedora 29 with clang 7.0.1, I didn't try other versions.  This can be worked around by installing clang 7.0.0 explicitly.

How reproducible:


Steps to Reproduce:
1. Try to compile a opencl kernel program using opencl kernel built-in functions on the Portable OpenCL Platform

Actual results:

The compile will fail with clBuildError and the CL_PROGRAM_BUILD_LOG will say include a line "'/usr/lib64/clang/7.0.0/include/opencl-c.h' file not found"


Expected results:

the build command will not fail and the warning is not emitted.

Additional info:

n/a

Comment 1 Fedora Update System 2019-02-09 04:26:58 UTC
pocl-1.2-1.fc29 has been submitted as an update to Fedora 29. https://bodhi.fedoraproject.org/updates/FEDORA-2019-d507f3fa47

Comment 2 Fedora Update System 2019-02-10 04:28:28 UTC
pocl-1.2-1.fc29 has been pushed to the Fedora 29 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2019-d507f3fa47

Comment 3 Fedora Update System 2019-02-13 02:47:14 UTC
pocl-1.2-1.fc29 has been pushed to the Fedora 29 stable repository. If problems still persist, please make note of it in this bug report.