Bug 1672014

Summary: Update to the latest Re2
Product: [Fedora] Fedora Reporter: Suvayu <fatkasuvayu>
Component: re2Assignee: Denis Arnaud <denis.arnaud_fedora>
Status: CLOSED ERRATA QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: unspecified Docs Contact:
Priority: unspecified    
Version: 31CC: denis.arnaud_fedora, hkario, lvrabec, rdieter, umar
Target Milestone: ---Keywords: Reopened
Target Release: ---   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: re2-20190801-1.fc29 re2-20190801-1.el8 Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2019-08-21 02:07:54 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Attachments:
Description Flags
Build attempt on Rawhide for qt5-qtwebengine - Failing on pulse audio none

Description Suvayu 2019-02-03 06:13:41 UTC
The current version available in the repos is 3 years old.  The latest release is from last month (Jan 2019): https://github.com/google/re2/releases

Comment 1 Lukas Vrabec 🐦 2019-08-03 14:35:39 UTC
I created PR to update re2 library to the latest version in Fedora Rawhide:

https://src.fedoraproject.org/rpms/re2/pull-request/1#

Copr builds available at:
https://copr.fedorainfracloud.org/coprs/lvrabec/re2/build/994236/

Comment 2 Fedora Update System 2019-08-05 09:02:25 UTC
FEDORA-2019-a49097c021 has been submitted as an update to Fedora 30. https://bodhi.fedoraproject.org/updates/FEDORA-2019-a49097c021

Comment 3 Fedora Update System 2019-08-05 09:09:47 UTC
FEDORA-2019-0f5dd9fe0d has been submitted as an update to Fedora 29. https://bodhi.fedoraproject.org/updates/FEDORA-2019-0f5dd9fe0d

Comment 4 Fedora Update System 2019-08-05 09:11:46 UTC
FEDORA-EPEL-2019-648f6bc55e has been submitted as an update to Fedora EPEL 8. https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2019-648f6bc55e

Comment 5 Fedora Update System 2019-08-05 09:14:19 UTC
FEDORA-EPEL-2019-6df6efa695 has been submitted as an update to Fedora EPEL 7. https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2019-6df6efa695

Comment 6 Fedora Update System 2019-08-06 01:27:08 UTC
re2-20190801-1.fc29 has been pushed to the Fedora 29 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2019-0f5dd9fe0d

Comment 7 Fedora Update System 2019-08-06 02:03:20 UTC
re2-20190801-1.el7 has been pushed to the Fedora EPEL 7 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2019-6df6efa695

Comment 8 Fedora Update System 2019-08-06 03:49:19 UTC
re2-20190801-1.fc30 has been pushed to the Fedora 30 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2019-a49097c021

Comment 9 Fedora Update System 2019-08-06 06:22:57 UTC
re2-20190801-1.el8 has been pushed to the Fedora EPEL 8 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2019-648f6bc55e

Comment 10 Rex Dieter 2019-08-06 18:39:45 UTC
Latest update breaks ABI without bumping library soname, which breaks the 2 packages in fedora that depend on it: 
qt5-qwebengine
perl-re-engine-RE2

After upgrading on f30, I see undefined symbols in each of them

ldd -r /usr/lib64/perl5/vendor_perl/auto/re/engine/RE2/RE2.so
...
undefined symbol: _ZNK3re23RE25MatchERKNS_11StringPieceEiiNS0_6AnchorEPS1_i     (/usr/lib64/perl5/vendor_perl/auto/re/engine/RE2/RE2.so)
undefined symbol: _ZNK3re23RE223NumberOfCapturingGroupsEv       (/usr/lib64/perl5/vendor_perl/auto/re/engine/RE2/RE2.so)

ldd -r /lib64/libQt5WebEngine.so.5

undefined symbol: _ZN3re23RE23Arg9parse_intEPKciPv      (/lib64/libQt5WebEngineCore.so.5)
undefined symbol: _ZN3re23RE23Arg12parse_stringEPKciPv  (/lib64/libQt5WebEngineCore.so.5)

Comment 11 Denis Arnaud 2019-08-07 13:29:37 UTC
Thanks!

I need to rebuild the packages depending on RE2 in a proper build-root.
 repoquery --tree-whatrequires --recursive re2

Comment 12 Rex Dieter 2019-08-07 14:07:12 UTC
Please bump library soname too, if possible.

Comment 13 Sammy 2019-08-08 12:13:40 UTC
It is also breaking kio when trying to connect to google drive from dolphin.
Downgrading solves the problem.

Comment 14 Denis Arnaud 2019-08-08 18:57:38 UTC
Created attachment 1601916 [details]
Build attempt on Rawhide for qt5-qtwebengine - Failing on pulse audio

Comment 15 Denis Arnaud 2019-08-08 19:00:00 UTC
--
Packages needed to be rebuilt:
repoquery --whatrequires re2
perl-re-engine-RE2
qt5-qtwebengine

--
Rebuilds on Rawhide:
* perl-re-engine-RE2 (successful): https://koji.fedoraproject.org/koji/taskinfo?taskID=36863602
* qt5-qtwebengine (failed): https://koji.fedoraproject.org/koji/taskinfo?taskID=36848498
--

qt5-qtwebengine fails to rebuild, but RE2 does not seem to be the cause here. I attached the error shown by the build attempt (https://bugzilla.redhat.com/attachment.cgi?id=1601916).

Comment 16 Rex Dieter 2019-08-09 21:17:22 UTC
qt5-qtwebengine rebuild,
https://koji.fedoraproject.org/koji/taskinfo?taskID=36890150

I still think it a good idea to bump library soname.  if that's not something you're able/willing to work on, would you not object to my committing it?

Comment 17 Denis Arnaud 2019-08-10 10:16:38 UTC
(In reply to Rex Dieter from comment #16)
>
> I still think it a good idea to bump library soname.  if that's not
> something you're able/willing to work on, would you not object to my
> committing it?

Sure, good idea, please proceed!

Comment 18 Ben Cotton 2019-08-13 16:59:11 UTC
This bug appears to have been reported against 'rawhide' during the Fedora 31 development cycle.
Changing version to '31'.

Comment 19 Ben Cotton 2019-08-13 17:10:29 UTC
This bug appears to have been reported against 'rawhide' during the Fedora 31 development cycle.
Changing version to 31.

Comment 20 Fedora Update System 2019-08-14 01:41:59 UTC
re2-20190801-1.fc29 has been pushed to the Fedora 29 stable repository. If problems still persist, please make note of it in this bug report.

Comment 21 Sammy 2019-08-14 17:28:48 UTC
To: Rex Dieter

Your latest re2 build on koji is missing epoch in the re2-devel package, creating a
dependency issue when upgrading.

Comment 22 Rex Dieter 2019-08-15 13:46:16 UTC
Look again at the latest build :)

Comment 23 Denis Arnaud 2019-08-15 19:37:47 UTC
The update is https://bodhi.fedoraproject.org/updates/FEDORA-2019-605dfb7384 (and the corresponding successful build https://koji.fedoraproject.org/koji/buildinfo?buildID=1355889)

Comment 24 Hubert Kario 2019-08-16 10:26:18 UTC
the Fedora29 package was not pulled out of the repo, the re2-20190801-1.fc29 is the breaking one!

Comment 25 Denis Arnaud 2019-08-16 12:52:11 UTC
(In reply to Hubert Kario from comment #24)
> the Fedora29 package was not pulled out of the repo, the re2-20190801-1.fc29
> is the breaking one!

Indeed. The https://bodhi.fedoraproject.org/updates/FEDORA-2019-605dfb7384 update (kindly contributed by Rex Dieter), which supersedes all the others on Fedora 29, delivers re2-20160401-11.fc29. Within a week (or before if there is good karma), it will reach the stable repository.

Comment 26 Fedora Update System 2019-08-21 02:07:54 UTC
re2-20190801-1.el8 has been pushed to the Fedora EPEL 8 stable repository. If problems still persist, please make note of it in this bug report.