Bug 1672389

Summary: dnf updates package when modular repository is unavailable
Product: [Fedora] Fedora Reporter: David Bauer <dbxx>
Component: dnfAssignee: rpm-software-management
Status: CLOSED DUPLICATE QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: unspecified Docs Contact:
Priority: unspecified    
Version: rawhideCC: awilliam, dbxx, dmach, jmracek, jrohel, mblaha, mhatina, packaging-team-maint, pkratoch, robatino, rpm-software-management, vmukhame
Target Milestone: ---   
Target Release: ---   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2019-02-06 14:15:09 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
Bug Depends On:    
Bug Blocks: 1574713    

Description David Bauer 2019-02-04 20:03:21 UTC
Description of problem:
This testcase was performed:
https://fedoraproject.org/wiki/QA:Testcase_Modularity_update_without_repos


Version-Release number of selected component (if applicable):
Fedora-Workstation-Live-x86_64-Rawhide-20190201.n.0
Fresh install, no updates installed

How reproducible:
During dnf update

Steps to Reproduce:
1. dnf update
2. dnf module enable nodejs:8
3. dnf module install nodejs:8
Installed:
nodejs         x86_64 1:8.12.0-1.module_2180+1761d862         rawhide-modular 7.3 M
npm            x86_64 1:6.4.1-1.8.12.0.1.module_2180+1761d862 rawhide-modular 3.5 M
4. dnf update --disablerepo=\*modular

Actual results:
After step 4. dnf tried to update npm and nodejs with rawhide as package source:
nodejs        x86_64        1:10.13.0-2.fc30                   rawhide        6.5 M
npm           x86_64        1:6.4.1-1.10.13.0.2.fc30           rawhide        3.6 M


Expected results:
The nodejs and npm package will not be updated to a newer version.
Additional info:

Comment 1 David Bauer 2019-02-04 20:24:57 UTC
This is a violation of the Fedora 30 Beta Release Criteria: https://fedoraproject.org/wiki/Fedora_30_Beta_Release_Criteria#Installing.2C_removing_and_updating_software - "The installed system must be able appropriately to install, remove, and update software with the default tool for the relevant software type in all release-blocking desktops (e.g. default graphical package manager). This includes downloading of packages to be installed/updated. "

Comment 2 Fedora Blocker Bugs Application 2019-02-04 20:27:16 UTC
Proposed as a Blocker for 30-beta by Fedora user dbxx using the blocker tracking app because:

 This is a violation of the Fedora 30 Beta Release Criteria: https://fedoraproject.org/wiki/Fedora_30_Beta_Release_Criteria#Installing.2C_removing_and_updating_software - "The installed system must be able appropriately to install, remove, and update software with the default tool for the relevant software type in all release-blocking desktops (e.g. default graphical package manager). This includes downloading of packages to be installed/updated."

Comment 3 Adam Williamson 2019-02-06 14:15:09 UTC

*** This bug has been marked as a duplicate of bug 1616167 ***