Bug 167351

Summary: Text entry in export wizard broken (with IBM JVM)
Product: [Retired] Red Hat Developer Suite Reporter: Andrew Overholt <overholt>
Component: RPM Plug-inAssignee: Matt Newsome <mnewsome>
Status: CLOSED WONTFIX QA Contact: eclipse-bugs
Severity: medium Docs Contact:
Priority: medium    
Version: 2.0CC: eclipse-bugs, patrickm
Target Milestone: ---   
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2015-05-05 08:26:14 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
Bug Depends On:    
Bug Blocks: 167352    

Description Andrew Overholt 2005-09-01 20:39:48 UTC
Description of problem:
1. Highlighting and typing over the current entries for version and release does
not replace text as expected.
2. New characters are entered twice in the release entry box.
3. Text entry in the version box does not work at all.

Version-Release number of selected component (if applicable):
eclipse-rpm-1.2.0-5

How reproducible:
Always (on IBM JVM).

Steps to Reproduce:
1. Try to export a previously-imported project
2. Try to change the release and/or version
  
Actual results:
See above.  Also, the terminal is spewed with NPEs with each key stroke:
Unhandled event loop exception
Reason:
java.lang.NullPointerException

Expected results:
Nothing echoed to terminal.  Export works.

Additional info:

Comment 6 Matt Newsome 2015-05-05 08:26:14 UTC
Closing this bug out due to its age and the assigned product.