Bug 1675135

Summary: switch to kube-system namespace secret monitoring
Product: OpenShift Container Platform Reporter: Gabe Montero <gmontero>
Component: ImageAssignee: Gabe Montero <gmontero>
Status: CLOSED ERRATA QA Contact: XiuJuan Wang <xiuwang>
Severity: medium Docs Contact:
Priority: unspecified    
Version: 4.1.0CC: aos-bugs, bparees, jokerman, mmccomas, wzheng
Target Milestone: ---   
Target Release: 4.1.0   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: Doc Type: No Doc Update
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2019-06-04 10:44:00 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description Gabe Montero 2019-02-11 20:21:29 UTC
Testing of rhel based image payloads started this past weekend.

That rhel based image payload content requires the coreos pull secret.

Our recent change to provide the jenkins images via the payload hence not required credentials irrespective of our other rhel images samples still pointing to registry.access.redhat.com (where we are waiting for the SD team to provide TBR credentials in the install)

So we accelerated the move to having credentials out of the box.

Specifically:
- the PR for this copies the coreos pull secret to the openshift namespace
- we now monitor the kube-system namespace for changes to the coreos-pull-secret
- we no longer monitor the operator namespace for secrets
- we updated the directions in the readme accordingly

QE will (once again) have to tweak their test cases accordingly.

Comment 1 Gabe Montero 2019-02-12 17:49:57 UTC
PR https://github.com/openshift/cluster-samples-operator/pull/99 is up

Comment 2 Gabe Montero 2019-02-13 00:25:58 UTC
PR has merged

Comment 3 XiuJuan Wang 2019-02-14 09:32:32 UTC
coreos-pull-secret under kube-system ns could be synced to samples-registry-credentials secret under openshift project.

$oc get clusterversion 
NAME      VERSION                             AVAILABLE   PROGRESSING   SINCE     STATUS
version   4.0.0-0.nightly-2019-02-13-204401   True        False         93m       Cluster version is 4.0.0-0.nightly-2019-02-13-204401

Comment 6 errata-xmlrpc 2019-06-04 10:44:00 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2019:0758