Bug 1676417

Summary: Can not use LDAP IDP on 4.0 cluster.
Product: OpenShift Container Platform Reporter: scheng
Component: AuthAssignee: Standa Laznicka <slaznick>
Status: CLOSED ERRATA QA Contact: scheng
Severity: high Docs Contact:
Priority: high    
Version: 4.1.0CC: aos-bugs, scheng, slaznick, sponnaga
Target Milestone: ---   
Target Release: 4.1.0   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: Doc Type: No Doc Update
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2019-06-04 10:44:00 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Comment 1 Standa Laznicka 2019-02-12 11:14:47 UTC
Fixed in https://github.com/openshift/cluster-authentication-operator/pull/68

Comment 3 Chuan Yu 2019-02-13 06:18:27 UTC
The PR was merged, move to ON_QA to verfiy.

Comment 4 scheng 2019-02-14 05:34:59 UTC
Verified

# oc get user
NAME      UID                                    FULL NAME      IDENTITIES
newton    045b85ce-301a-11e9-9128-0a580a82001b   Isaac Newton   ldapidp:uid=newton,dc=example,dc=com


# oc get clusterversion version -o json |jq .status.desired
{
  "image": "registry.svc.ci.openshift.org/ocp/release@sha256:8168c9d2a331b6e8ca5e9b08f623d7f0ff50277bbc63fa71b1bc2a8c806f2ddf",
  "version": "4.0.0-0.nightly-2019-02-13-204401"
}

Comment 7 errata-xmlrpc 2019-06-04 10:44:00 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2019:0758