Bug 1679774

Summary: THT should have an option to disable Panko completely.
Product: Red Hat OpenStack Reporter: Vinay Kapalavai <vkapalav>
Component: openstack-tripleo-heat-templatesAssignee: Vinay Kapalavai <vkapalav>
Status: CLOSED DUPLICATE QA Contact: Nataf Sharabi <nsharabi>
Severity: high Docs Contact:
Priority: high    
Version: 14.0 (Rocky)CC: aaustin, jamsmith, k-akatsuka, knoha, lnatapov, mburns, mfuruta, mmagr, nsharabi, pkilambi, rheslop, slinaber, ssmolyak, vkapalav
Target Milestone: z4Keywords: TestOnly, Triaged, ZStream
Target Release: 14.0 (Rocky)   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: openstack-tripleo-heat-templates-9.2.1-0.20190119154864.el7ost Doc Type: Bug Fix
Doc Text:
Prior to this update, there was no way to completely disable the Panko service using the Tripleo heat templates. This is resolved with the newly added parameter, `CeilometerEnablePanko`. To disable the Panko service, set this parameter to False.
Story Points: ---
Clone Of: 1613601 Environment:
Last Closed: 2019-07-26 21:04:59 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Bug Depends On: 1613601, 1701360    
Bug Blocks: 1581780    

Comment 3 Vinay Kapalavai 2019-02-26 16:14:24 UTC
*** Bug 1653357 has been marked as a duplicate of this bug. ***

Comment 11 Nataf Sharabi 2019-05-08 11:07:24 UTC
Hi,

I've installed puddle 2019-04-25.1 &

Added the following script to the installation:

- /usr/share/openstack-tripleo-heat-templates/environments/disable-panko.yaml


(undercloud) [stack@undercloud-0 ~]$ openstack server list                                                                                                                                   
+--------------------------------------+--------------+--------+------------------------+----------------+------------+                                                                      
| ID                                   | Name         | Status | Networks               | Image          | Flavor     |                                                                      
+--------------------------------------+--------------+--------+------------------------+----------------+------------+                                                                      
| c2ee79d4-d31b-4d4d-bba8-104a7897d87e | controller-2 | ACTIVE | ctlplane=192.168.24.16 | overcloud-full | controller |                                                                      
| 32257f42-10bb-41cb-ac62-c7c8dd71fd99 | controller-1 | ACTIVE | ctlplane=192.168.24.13 | overcloud-full | controller |                                                                      
| 91931067-7e52-4a57-b580-7392585e3a6f | compute-1    | ACTIVE | ctlplane=192.168.24.8  | overcloud-full | compute    |                                                                      
| 8bc82714-c79b-4352-a129-a02a068bbc85 | controller-0 | ACTIVE | ctlplane=192.168.24.10 | overcloud-full | controller |                                                                      
| 2607d4d4-8521-4918-90c3-de2bdd94c8be | compute-0    | ACTIVE | ctlplane=192.168.24.24 | overcloud-full | compute    |                                                                      
+--------------------------------------+--------------+--------+------------------------+----------------+------------+ 

All controller nodes are missing panko-api &   
[heat-admin@controller-2 ~]$ sudo docker ps | grep panko
[heat-admin@controller-2 ~]$ sudo docker ps | grep ceil
608730de58b3        192.168.24.1:8787/rhosp14/openstack-ceilometer-notification:2019-04-23.1     "kolla_start"            7 days ago          Restarting (2) 2 days ago                       ceilometer_agent_notification
e8ad9ea0af11        192.168.24.1:8787/rhosp14/openstack-ceilometer-central:2019-04-23.1          "kolla_start"            7 days ago          Up 7 days (healthy)                             ceilometer_agent_central


Since ceilometer-notification is restarting - I'm blocking this bug by BZ-1701360.

Comment 13 Vinay Kapalavai 2019-07-26 21:00:46 UTC
*** Bug 1701360 has been marked as a duplicate of this bug. ***

Comment 14 Vinay Kapalavai 2019-07-26 21:04:59 UTC

*** This bug has been marked as a duplicate of bug 1701360 ***