Bug 1680085

Summary: OS X clients disconnect from SMB mount points
Product: [Community] GlusterFS Reporter: ryan
Component: gluster-smbAssignee: Anoop C S <anoopcs>
Status: CLOSED WORKSFORME QA Contact:
Severity: high Docs Contact:
Priority: medium    
Version: 4.1CC: anoopcs, bugs, pasik
Target Milestone: ---Keywords: ZStream
Target Release: ---   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2019-11-18 13:35:55 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description ryan 2019-02-22 17:03:34 UTC
Description of problem:
Re-occurnace of 1636246 

Version-Release number of selected component (if applicable):
4.9.4

How reproducible:
Appears to be random, but only occurs on OS X clients.


Steps to Reproduce:
1. Mount gluster fs via SMB on OS X client
2. Browse, write and read files via SMB 
3. Eventually you will get recorring reconnect messages from OS X and the mount point will hang

Actual results:
Mount point hangs due to missing file descriptor

Expected results:
File descriptor should exist

Additional info:
Brick log:

[root@hostname ~]# cat /var/log/glusterfs/bricks/mnt-h1a-data.log
[2019-02-22 10:27:01.148578] E [MSGID: 113040] [posix-helpers.c:1725:__posix_fd_ctx_get] 0-mcv01-posix: Failed to get anonymous fd for real_path: /mnt/h1a/data/.glusterfs/64/be/64be69f2-94d1-417d-83f4-049e169440be. [No such file or directory]
[2019-02-22 10:27:01.155221] E [MSGID: 113040] [posix-helpers.c:1725:__posix_fd_ctx_get] 0-mcv01-posix: Failed to get anonymous fd for real_path: /mnt/h1a/data/.glusterfs/81/9d/819dc5d8-aea9-4baa-b8aa-f93328c1d7cc. [No such file or directory]
[2019-02-22 10:27:01.158948] E [MSGID: 113040] [posix-helpers.c:1725:__posix_fd_ctx_get] 0-mcv01-posix: Failed to get anonymous fd for real_path: /mnt/h1a/data/.glusterfs/04/1d/041d6ea7-41f7-4f0a-a251-56f7767f3f8e. [No such file or directory]
The message "E [MSGID: 113040] [posix-helpers.c:1725:__posix_fd_ctx_get] 0-mcv01-posix: Failed to get anonymous fd for real_path: /mnt/h1a/data/.glusterfs/64/be/64be69f2-94d1-417d-83f4-049e169440be. [No such file or directory]" repeated 7 times between [2019-02-22 10:27:01.148578] and [2019-02-22 10:28:17.983682]
The message "E [MSGID: 113040] [posix-helpers.c:1725:__posix_fd_ctx_get] 0-mcv01-posix: Failed to get anonymous fd for real_path: /mnt/h1a/data/.glusterfs/81/9d/819dc5d8-aea9-4baa-b8aa-f93328c1d7cc. [No such file or directory]" repeated 7 times between [2019-02-22 10:27:01.155221] and [2019-02-22 10:28:17.985446]
The message "E [MSGID: 113040] [posix-helpers.c:1725:__posix_fd_ctx_get] 0-mcv01-posix: Failed to get anonymous fd for real_path: /mnt/h1a/data/.glusterfs/04/1d/041d6ea7-41f7-4f0a-a251-56f7767f3f8e. [No such file or directory]" repeated 7 times between [2019-02-22 10:27:01.158948] and [2019-02-22 10:28:17.986679]
[2019-02-22 10:31:21.537897] E [MSGID: 113040] [posix-helpers.c:1725:__posix_fd_ctx_get] 0-mcv01-posix: Failed to get anonymous fd for real_path: /mnt/h1a/data/.glusterfs/81/9d/819dc5d8-aea9-4baa-b8aa-f93328c1d7cc. [No such file or directory]
[2019-02-22 10:31:21.684943] E [MSGID: 113040] [posix-helpers.c:1725:__posix_fd_ctx_get] 0-mcv01-posix: Failed to get anonymous fd for real_path: /mnt/h1a/data/.glusterfs/04/1d/041d6ea7-41f7-4f0a-a251-56f7767f3f8e. [No such file or directory]
[2019-02-22 10:31:21.726305] E [MSGID: 113040] [posix-helpers.c:1725:__posix_fd_ctx_get] 0-mcv01-posix: Failed to get anonymous fd for real_path: /mnt/h1a/data/.glusterfs/64/be/64be69f2-94d1-417d-83f4-049e169440be. [No such file or directory]
The message "E [MSGID: 113040] [posix-helpers.c:1725:__posix_fd_ctx_get] 0-mcv01-posix: Failed to get anonymous fd for real_path: /mnt/h1a/data/.glusterfs/81/9d/819dc5d8-aea9-4baa-b8aa-f93328c1d7cc. [No such file or directory]" repeated 3 times between [2019-02-22 10:31:21.537897] and [2019-02-22 10:32:07.223785]
The message "E [MSGID: 113040] [posix-helpers.c:1725:__posix_fd_ctx_get] 0-mcv01-posix: Failed to get anonymous fd for real_path: /mnt/h1a/data/.glusterfs/04/1d/041d6ea7-41f7-4f0a-a251-56f7767f3f8e. [No such file or directory]" repeated 5 times between [2019-02-22 10:31:21.684943] and [2019-02-22 10:32:07.397923]
The message "E [MSGID: 113040] [posix-helpers.c:1725:__posix_fd_ctx_get] 0-mcv01-posix: Failed to get anonymous fd for real_path: /mnt/h1a/data/.glusterfs/64/be/64be69f2-94d1-417d-83f4-049e169440be. [No such file or directory]" repeated 7 times between [2019-02-22 10:31:21.726305] and [2019-02-22 10:32:07.455858]

Comment 2 ryan 2019-02-26 15:10:13 UTC
Please let me know if you need any more details around this. It manifests itself in the same way as bug 1636246 which should have been resolved.

Comment 3 Anoop C S 2019-06-07 11:15:21 UTC
(In reply to ryan from comment #0)
> Description of problem:
> Re-occurnace of 1636246 
> 
> Version-Release number of selected component (if applicable):
> 4.9.4

Based on the version specified above changing the Product and Component fields.

Also please re-evaluate the relevance this bug and set the version accordingly.

Comment 4 ryan 2019-06-10 14:25:35 UTC
Hi Anoop,

I'm currently unable to test this due to issues found on bug 1716440.

Best,
Ryan

Comment 5 Anoop C S 2019-07-19 10:22:12 UTC
(In reply to ryan from comment #4)
> Hi Anoop,
> 
> I'm currently unable to test this due to issues found on bug 1716440.

Do you still see panic with updated packages? I am really confused with your comment on bug 1716440.

Comment 6 Anoop C S 2019-07-25 04:22:12 UTC
@Ryan,

What about this one? Does this still hold provided the fact that bug #1716440 is no longer relevant? Or is this related to bug #1728183?

Comment 7 ryan 2019-10-22 10:18:15 UTC
Hi Anoop,

I'm unable to recreate this issue at the moment due to  #1728183?

Comment 8 ryan 2019-11-18 12:24:06 UTC
Hi Anoop,

I can confirm that the issue is resolved when using the following versions and SMB share config:
Gluster 6.5
Samba 4.10 with gluster_vfs built against Gluster 6.5 (Not the default 3.12) - OR - Gluster 6.5 using op-version 40100 and normal gluster_vfs package

share config:
[test-share]
read only = no
guest ok = yes
vfs objects = catia fruit streams_xattr glusterfs
glusterfs:volume = mcv01
path="/data/test"
valid users = "nobody" @"nas_users"

Many thanks for the assistance.

Best,
Ryan

Comment 9 Anoop C S 2019-11-18 13:35:55 UTC
@Ryan,

Thanks for your confirmation. Closing the bug report.