Bug 1680221

Summary: Not explicit conflicts with yum-utils
Product: [Fedora] Fedora Reporter: Remi Collet <fedora>
Component: dnf-plugins-coreAssignee: Michal Domonkos <mdomonko>
Status: CLOSED WONTFIX QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: unspecified Docs Contact:
Priority: unspecified    
Version: 29CC: carl, dmach, grgoffe, hongjiu.lu, jan.public, jmracek, jrefl5, mail, mblaha, mdomonko, musuruan, packaging-team-maint, pkratoch, rpm-software-management, sgiurgiu11, vmukhame
Target Milestone: ---Keywords: Triaged
Target Release: ---   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2019-09-03 11:31:32 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Embargoed:

Description Remi Collet 2019-02-23 07:22:10 UTC
dnf-utils is pulled by recent updates (weak dependency), so dnf try to install it by default.


But, if yum-utils is installed:

Error: Transaction check error:
  file /usr/bin/debuginfo-install from install of dnf-utils-4.0.4-1.fc29.noarch conflicts with file from package yum-utils-1.1.31-518.fc29.noarch
  file /usr/bin/find-repos-of-install from install of dnf-utils-4.0.4-1.fc29.noarch conflicts with file from package yum-utils-1.1.31-518.fc29.noarch
  file /usr/bin/needs-restarting from install of dnf-utils-4.0.4-1.fc29.noarch conflicts with file from package yum-utils-1.1.31-518.fc29.noarch
  file /usr/bin/package-cleanup from install of dnf-utils-4.0.4-1.fc29.noarch conflicts with file from package yum-utils-1.1.31-518.fc29.noarch
  file /usr/bin/repo-graph from install of dnf-utils-4.0.4-1.fc29.noarch conflicts with file from package yum-utils-1.1.31-518.fc29.noarch
  file /usr/bin/repoclosure from install of dnf-utils-4.0.4-1.fc29.noarch conflicts with file from package yum-utils-1.1.31-518.fc29.noarch
...


1/ I think an explicit conflicts should be added in this package

2/ A better weak dependency is needed to avoid dnf pulling it (and, perhaps, later, have to obsolete yum-utils)

Comment 1 Remi Collet 2019-02-23 07:24:20 UTC
I notice the conflicts is here

Conflicts:      yum-utils < 1.1.31-513

But is not correct

# rpm -q yum-utils
yum-utils-1.1.31-518.fc29.noarch

Comment 2 Remi Collet 2019-02-23 07:30:28 UTC
Reported for mock as bug #1680222

Comment 3 Marek Blaha 2019-02-25 12:48:45 UTC
*** Bug 1680252 has been marked as a duplicate of this bug. ***

Comment 4 Marek Blaha 2019-02-25 12:51:56 UTC
*** Bug 1680390 has been marked as a duplicate of this bug. ***

Comment 5 James Crawford 2019-02-26 21:20:17 UTC
Do we have a fix/workaround?
I have not been able to apply updates to my ferora 29 system since 2/22.

Comment 6 sgiurgiu11 2019-02-27 12:47:58 UTC
(In reply to James Crawford from comment #5)
> Do we have a fix/workaround?
> I have not been able to apply updates to my ferora 29 system since 2/22.

I have uninstalled yum-utils and installed dnf-utils. After that updates were installed without a hitch.

Comment 7 James Crawford 2019-02-28 00:27:26 UTC
sgiurgiu11 Thanks that did the trick for me also.

Comment 8 Michal Domonkos 2019-02-28 16:12:40 UTC
Upstream PR:
https://github.com/rpm-software-management/dnf-plugins-core/pull/327

Comment 9 Sam Tuke 2019-03-02 11:53:31 UTC
(In reply to sgiurgiu11 from comment #6)
> (In reply to James Crawford from comment #5)
> > Do we have a fix/workaround?
> > I have not been able to apply updates to my ferora 29 system since 2/22.
> 
> I have uninstalled yum-utils and installed dnf-utils. After that updates
> were installed without a hitch.

Works for me too.

Comment 10 Michal Domonkos 2019-09-03 11:15:18 UTC
*** Bug 1611993 has been marked as a duplicate of this bug. ***

Comment 11 Michal Domonkos 2019-09-03 11:31:32 UTC
The yum-3 stack is completely removed from Fedora 31 and we no longer plan any yum-utils updates in earlier Fedora releases, hence closing this bug.

(FTR, this particular issue seems to be fixed in Fedora 30.)

Comment 12 Michal Domonkos 2019-09-03 11:33:51 UTC
Note that the original PR linked above was later closed and replaced by the following one:
https://github.com/rpm-software-management/dnf-plugins-core/pull/344

Comment 13 Michal Domonkos 2019-09-03 15:36:09 UTC
... which was later reverted for Fedora (I almost forgot):
https://github.com/rpm-software-management/dnf-plugins-core/pull/352/