Bug 1680252

Summary: Transaction check error:
Product: [Fedora] Fedora Reporter: James Crawford <jrefl5>
Component: dnfAssignee: rpm-software-management
Status: CLOSED DUPLICATE QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: medium Docs Contact:
Priority: unspecified    
Version: 29CC: dmach, jmracek, jrohel, mblaha, mhatina, packaging-team-maint, pkratoch, rpm-software-management, vmukhame
Target Milestone: ---   
Target Release: ---   
Hardware: x86_64   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2019-02-25 12:48:45 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Embargoed:

Description James Crawford 2019-02-23 11:38:57 UTC
Description of problem: Today DNF throws the following after downloading new packages on >dnf update --refresh

Delta RPMs reduced 74.3 MB of updates to 26.8 MB (63.1% saved)
Running transaction check
Transaction check succeeded.
Running transaction test
The downloaded packages were saved in cache until the next successful transaction.
You can remove cached packages by executing 'dnf clean packages'.
Error: Transaction check error:
  file /usr/bin/debuginfo-install from install of dnf-utils-4.0.4-1.fc29.noarch conflicts with file from package yum-utils-1.1.31-518.fc29.noarch
  file /usr/bin/find-repos-of-install from install of dnf-utils-4.0.4-1.fc29.noarch conflicts with file from package yum-utils-1.1.31-518.fc29.noarch
  file /usr/bin/needs-restarting from install of dnf-utils-4.0.4-1.fc29.noarch conflicts with file from package yum-utils-1.1.31-518.fc29.noarch
  file /usr/bin/package-cleanup from install of dnf-utils-4.0.4-1.fc29.noarch conflicts with file from package yum-utils-1.1.31-518.fc29.noarch
  file /usr/bin/repo-graph from install of dnf-utils-4.0.4-1.fc29.noarch conflicts with file from package yum-utils-1.1.31-518.fc29.noarch
  file /usr/bin/repoclosure from install of dnf-utils-4.0.4-1.fc29.noarch conflicts with file from package yum-utils-1.1.31-518.fc29.noarch
  file /usr/bin/repodiff from install of dnf-utils-4.0.4-1.fc29.noarch conflicts with file from package yum-utils-1.1.31-518.fc29.noarch
  file /usr/bin/repomanage from install of dnf-utils-4.0.4-1.fc29.noarch conflicts with file from package yum-utils-1.1.31-518.fc29.noarch
  file /usr/bin/repoquery from install of dnf-utils-4.0.4-1.fc29.noarch conflicts with file from package yum-utils-1.1.31-518.fc29.noarch
  file /usr/bin/reposync from install of dnf-utils-4.0.4-1.fc29.noarch conflicts with file from package yum-utils-1.1.31-518.fc29.noarch
  file /usr/bin/repotrack from install of dnf-utils-4.0.4-1.fc29.noarch conflicts with file from package yum-utils-1.1.31-518.fc29.noarch
  file /usr/bin/yum-builddep from install of dnf-utils-4.0.4-1.fc29.noarch conflicts with file from package yum-utils-1.1.31-518.fc29.noarch
  file /usr/bin/yum-config-manager from install of dnf-utils-4.0.4-1.fc29.noarch conflicts with file from package yum-utils-1.1.31-518.fc29.noarch
  file /usr/bin/yum-debug-dump from install of dnf-utils-4.0.4-1.fc29.noarch conflicts with file from package yum-utils-1.1.31-518.fc29.noarch
  file /usr/bin/yum-debug-restore from install of dnf-utils-4.0.4-1.fc29.noarch conflicts with file from package yum-utils-1.1.31-518.fc29.noarch
  file /usr/bin/yumdownloader from install of dnf-utils-4.0.4-1.fc29.noarch conflicts with file from package yum-utils-1.1.31-518.fc29.noarch
  file /usr/share/man/man1/debuginfo-install.1.gz from install of dnf-utils-4.0.4-1.fc29.noarch conflicts with file from package yum-utils-1.1.31-518.fc29.noarch
  file /usr/share/man/man1/find-repos-of-install.1.gz from install of dnf-utils-4.0.4-1.fc29.noarch conflicts with file from package yum-utils-1.1.31-518.fc29.noarch
  file /usr/share/man/man1/needs-restarting.1.gz from install of dnf-utils-4.0.4-1.fc29.noarch conflicts with file from package yum-utils-1.1.31-518.fc29.noarch
  file /usr/share/man/man1/package-cleanup.1.gz from install of dnf-utils-4.0.4-1.fc29.noarch conflicts with file from package yum-utils-1.1.31-518.fc29.noarch
  file /usr/share/man/man1/repo-graph.1.gz from install of dnf-utils-4.0.4-1.fc29.noarch conflicts with file from package yum-utils-1.1.31-518.fc29.noarch
  file /usr/share/man/man1/repoclosure.1.gz from install of dnf-utils-4.0.4-1.fc29.noarch conflicts with file from package yum-utils-1.1.31-518.fc29.noarch
  file /usr/share/man/man1/repodiff.1.gz from install of dnf-utils-4.0.4-1.fc29.noarch conflicts with file from package yum-utils-1.1.31-518.fc29.noarch
  file /usr/share/man/man1/repomanage.1.gz from install of dnf-utils-4.0.4-1.fc29.noarch conflicts with file from package yum-utils-1.1.31-518.fc29.noarch
  file /usr/share/man/man1/repoquery.1.gz from install of dnf-utils-4.0.4-1.fc29.noarch conflicts with file from package yum-utils-1.1.31-518.fc29.noarch
  file /usr/share/man/man1/reposync.1.gz from install of dnf-utils-4.0.4-1.fc29.noarch conflicts with file from package yum-utils-1.1.31-518.fc29.noarch
  file /usr/share/man/man1/repotrack.1.gz from install of dnf-utils-4.0.4-1.fc29.noarch conflicts with file from package yum-utils-1.1.31-518.fc29.noarch
  file /usr/share/man/man1/yum-builddep.1.gz from install of dnf-utils-4.0.4-1.fc29.noarch conflicts with file from package yum-utils-1.1.31-518.fc29.noarch
  file /usr/share/man/man1/yum-config-manager.1.gz from install of dnf-utils-4.0.4-1.fc29.noarch conflicts with file from package yum-utils-1.1.31-518.fc29.noarch
  file /usr/share/man/man1/yum-debug-dump.1.gz from install of dnf-utils-4.0.4-1.fc29.noarch conflicts with file from package yum-utils-1.1.31-518.fc29.noarch
  file /usr/share/man/man1/yum-debug-restore.1.gz from install of dnf-utils-4.0.4-1.fc29.noarch conflicts with file from package yum-utils-1.1.31-518.fc29.noarch
  file /usr/share/man/man1/yum-utils.1.gz from install of dnf-utils-4.0.4-1.fc29.noarch conflicts with file from package yum-utils-1.1.31-518.fc29.noarch
  file /usr/share/man/man1/yumdownloader.1.gz from install of dnf-utils-4.0.4-1.fc29.noarch conflicts with file from package yum-utils-1.1.31-518.fc29.noarch




Version-Release number of selected component (if applicable): current DNF as of Friday 5:00PM MST (UTC -7:00).


How reproducible: looks to be 100% on my system.


Steps to Reproduce:
1.dnf update --refresh
2.
3.

Actual results: see above


Expected results: Successful update of packages 


Additional info:

Comment 1 Marek Blaha 2019-02-25 12:48:45 UTC

*** This bug has been marked as a duplicate of bug 1680221 ***