Bug 168048

Summary: 2.6.12-1.1447_FC4xen0 fails to boot
Product: [Fedora] Fedora Reporter: Ed Greenberg <edg>
Component: xenAssignee: Rik van Riel <riel>
Status: CLOSED RAWHIDE QA Contact:
Severity: medium Docs Contact:
Priority: medium    
Version: 4CC: tom-fedora
Target Milestone: ---   
Target Release: ---   
Hardware: i386   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2006-02-24 15:03:15 EST Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:

Description Ed Greenberg 2005-09-11 12:46:04 EDT
Description of problem:
xen kernel fails to start

Version-Release number of selected component (if applicable):
2.6.12-1.1447_FC4xen0

How reproducible:
always

Steps to Reproduce:
1 fresh install FC4
2 do a full yum update
3 yum install xen
4 yum install kernel-xen0 kernel-xenU
5 reboot to 1447_FC4xen0 kernel
  
Actual results:
system hangs at:
Switching to new root
unmounting old /proc
unmounting old /sys


Expected results:
well, it should boot, correct? 

Additional info:
The console still echoes, and the three-finger-salute still does an orderly 
shutdown, but the system never gets past the above.

I've tried this on two systems:
* Dell Precision 410
* Toshiba Tecra 8100
Same install, same yum update first, same xen packages, same result.
Comment 1 Ed Greenberg 2005-09-11 12:47:28 EDT
None of the five bugs that the search string 'xen' seem to apply to this. 
Comment 2 Rik van Riel 2005-09-11 16:45:50 EDT
Could you please try the RPMs from http://people.redhat.com/riel ?

I have recently committed a fix for this problem.
Comment 3 Kiyo Sekimoto 2005-09-28 22:18:43 EDT
I have tested xen-3.0-0.20050912.fc4.i386.rpm with kernel at 1456 level. The
kernel at 1454 level just did not boot at all. the xen-3.0 solved this problem
in any way but runs too slow and boot of xen0 kernel stopes at starting ntpd.
So, the symptom has been changed but xen0 does not complete booting. 

Kiyo.
Comment 4 Stephen Tweedie 2006-02-24 15:03:15 EST
The original problem has been fixed, and a large number of updates have been
released since that point too.  If you still have problems with FC5test3 or
later, please open a new bug report.