Bug 1688934 (CVE-2019-9639)

Summary: CVE-2019-9639 php: Uninitialized read in exif_process_IFD_in_MAKERNOTE
Product: [Other] Security Response Reporter: Laura Pardo <lpardo>
Component: vulnerabilityAssignee: Red Hat Product Security <security-response-team>
Status: CLOSED ERRATA QA Contact:
Severity: medium Docs Contact:
Priority: medium    
Version: unspecifiedCC: fedora, hhorak, jorton, rcollet, webstack-team
Target Milestone: ---Keywords: Security
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: php 7.1.27, php 7.2.16, php 7.3.3 Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2019-08-19 08:47:55 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Bug Depends On: 1690540, 1688936, 1690539, 1709269, 1709274    
Bug Blocks: 1688949    

Description Laura Pardo 2019-03-14 18:08:05 UTC
An issue was discovered in the EXIF component in PHP before 7.1.27, 7.2.x before 7.2.16, and 7.3.x before 7.3.3. There is an uninitialized read in exif_process_IFD_in_MAKERNOTE because of mishandling the data_len variable.


Upstream Bug:
https://bugs.php.net/bug.php?id=77659

Upstream Patch:
http://git.php.net/?p=php-src.git;a=commitdiff;h=b82437eeddadf6a3a8c0f492acb6861682cd4d93

Comment 1 Laura Pardo 2019-03-14 18:08:24 UTC
Created php tracking bugs for this issue:

Affects: fedora-all [bug 1688936]

Comment 4 Riccardo Schirone 2019-05-13 10:06:38 UTC
Red Hat Enterprise Linux 5, 6, and 7 are not affected by this flaw as they do not include the vulnerable code.

Comment 8 errata-xmlrpc 2019-08-19 08:42:56 UTC
This issue has been addressed in the following products:

  Red Hat Software Collections for Red Hat Enterprise Linux 7
  Red Hat Software Collections for Red Hat Enterprise Linux 7.4 EUS
  Red Hat Software Collections for Red Hat Enterprise Linux 7.5 EUS
  Red Hat Software Collections for Red Hat Enterprise Linux 7.6 EUS

Via RHSA-2019:2519 https://access.redhat.com/errata/RHSA-2019:2519

Comment 9 Product Security DevOps Team 2019-08-19 08:47:55 UTC
This bug is now closed. Further updates for individual products will be reflected on the CVE page(s):

https://access.redhat.com/security/cve/cve-2019-9639

Comment 10 errata-xmlrpc 2019-11-01 13:00:53 UTC
This issue has been addressed in the following products:

  Red Hat Software Collections for Red Hat Enterprise Linux 7
  Red Hat Software Collections for Red Hat Enterprise Linux 7.5 EUS
  Red Hat Software Collections for Red Hat Enterprise Linux 7.6 EUS
  Red Hat Software Collections for Red Hat Enterprise Linux 7.7 EUS

Via RHSA-2019:3299 https://access.redhat.com/errata/RHSA-2019:3299