Bug 1689910

Summary: [RFE] auto-completion for satellite-maintain command does not work.
Product: Red Hat Satellite Reporter: Jameer Pathan <jpathan>
Component: Foreman MaintainAssignee: Anurag Patel <apatel>
Status: CLOSED WONTFIX QA Contact: Jameer Pathan <jpathan>
Severity: medium Docs Contact:
Priority: medium    
Version: 6.5.0CC: apatel, inecas, kgaikwad, mbacovsk
Target Milestone: UnspecifiedKeywords: FutureFeature, Triaged, UserExperience
Target Release: Unused   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2020-05-01 14:14:46 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description Jameer Pathan 2019-03-18 12:26:54 UTC
Description of problem:
auto-completion for satellite-maintain command does not work.

Version-Release number of selected component (if applicable):
@satellite 6.5.0 snap 20
@satellite-maintain-0.0.1-1.el7sat.noarch

How reproducible:
always

Steps to Reproduce:
1. use satellite-maintain command while trying to auto-complete command
by pressing tab


Actual results:
auto-completion for satellite-maintain command does not work.

Expected results:
auto-completion for satellite-maintain command should work.

Additional info:

Comment 3 Martin Bacovsky 2019-03-18 13:43:08 UTC
Adding completion config should fix that

cat > /etc/bash_completion.d/satellite_maintain <<EOF
#
# Satellite Maintain bash completion script
#

complete -C foreman-maintain-complete -o nospace satellite-maintain
EOF

Comment 5 Bryan Kearney 2020-05-01 14:14:46 UTC
Thank you for your interest in Satellite 6. We have evaluated this request, and while we recognize that it is a valid request, we do not expect this to be implemented in the product in the foreseeable future. This is due to other priorities for the product, and not a reflection on the request itself. We are therefore closing this out as WONTFIX. If you have any concerns about this, please do not reopen. Instead, feel free to contact Red Hat Technical Support. Thank you.