Bug 1690192

Summary: federation image is named differently in OCP and Origin
Product: OpenShift Container Platform Reporter: Clayton Coleman <ccoleman>
Component: FederationAssignee: Paul Morie <pmorie>
Status: CLOSED ERRATA QA Contact: Qin Ping <piqin>
Severity: urgent Docs Contact:
Priority: unspecified    
Version: 4.1.0CC: nagrawal, tbielawa
Target Milestone: ---   
Target Release: 4.1.0   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2019-06-04 10:46:02 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description Clayton Coleman 2019-03-19 00:59:40 UTC
The Origin image is federation-controllers (publishing to ocp/4.0 via CI) and the OCP image name is federation-v2 (published back to ocp/4.0-art-latest via quay).

The names must be consistent.  Please fix ASAP.

Comment 1 Paul Morie 2019-03-19 18:43:34 UTC
I will have the OCP image name changed.

Comment 2 Paul Morie 2019-03-21 17:26:25 UTC
Configuration change is made, will be fixed in next nightly build: https://github.com/openshift/ocp-build-data/blob/openshift-4.0/images/federation-v2.yml

Comment 4 Qin Ping 2019-03-25 03:22:40 UTC
Now, the federation image name
1. in OCP is: openshift/ose-federation-controller, the name in quay is: ocp-v4.0-art-dev:v4.0.z-n-ose-federation-controller
2. in origin is: origin-federation-controller

Comment 5 Tim Bielawa 2019-03-25 14:05:43 UTC
I have deleted this

$ oc delete istag/4.0-art-latest:federation-v2 -n ocp                                                                                                 
imagestreamtag.image.openshift.io "4.0-art-latest:federation-v2" deleted

Comment 7 errata-xmlrpc 2019-06-04 10:46:02 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2019:0758