Bug 1690377

Summary: default to en_SG for Singapore
Product: [Fedora] Fedora Reporter: Jens Petersen <petersen>
Component: langtableAssignee: Mike FABIAN <mfabian>
Status: CLOSED NEXTRELEASE QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: unspecified Docs Contact:
Priority: unspecified    
Version: 30CC: i18n-bugs, mfabian
Target Milestone: ---   
Target Release: ---   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2019-06-05 15:39:43 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description Jens Petersen 2019-03-19 11:16:40 UTC
Description of problem:
I think it makes more sense to default to en_SG for Singapore
- we don't really have en_SG translations in Fedora anyway.
Also probably default SG keyboard could just be US
(given that CN = US anyway).

Version-Release number of selected component (if applicable):
langtable-0.0.41-2.fc30

Steps to Reproduce:
1. Install Fedora in Singapore

Actual results:
Default to zh_SG

Expected results:
English since zh_SG is not translated and no easy fallback even to zh_CN.

Additional info:
(Also dunno why anaconda lists cmn_TW.utf8: it really should not)

Comment 1 Mike FABIAN 2019-06-05 15:39:43 UTC
Fixed in langtable 0.0.43:

https://github.com/mike-fabian/langtable/releases/tag/0.0.43
- Fix ranks for "en" and "zh" in "SG", English should be the default for "SG"

So this should be fixed in Fedora 31.