Bug 1691537

Summary: fedora scientific 30 failed to build
Product: [Fedora] Fedora Reporter: Amit Saha <amitsaha.in>
Component: spin-kickstartsAssignee: Václav Pavlín <vpavlin>
Status: CLOSED ERRATA QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: unspecified Docs Contact:
Priority: unspecified    
Version: 30CC: admiller, awilliam, bcotton, bruno, dustymabe, kevin, vanmeeuwen+fedora, vpavlin
Target Milestone: ---   
Target Release: ---   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard: AcceptedFreezeException
Fixed In Version: Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2019-03-29 19:15:01 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Bug Depends On:    
Bug Blocks: 1574714    

Description Amit Saha 2019-03-21 20:36:29 UTC
Description of problem:

The Python2 packages for Fedora Scientific are not available.

https://koji.fedoraproject.org/koji/taskinfo?taskID=33656158

Pull request: https://pagure.io/fedora-kickstarts/pull-request/508


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

Comment 1 Fedora Blocker Bugs Application 2019-03-22 14:38:12 UTC
Proposed as a Freeze Exception for 30-beta by Fedora user bcotton using the blocker tracking app because:

 Since we are no-go for F30 Beta, we should allow another spin to build.

Comment 2 Adam Williamson 2019-03-22 15:39:58 UTC
Marking accepted as this falls under the 'automatic freeze exceptions' policy: "Bugs which entirely prevent the composition of one or more of the non-release-blocking images required to be built for a currently-pending (pre-)release" - https://fedoraproject.org/wiki/QA:SOP_freeze_exception_bug_process#Automatic_freeze_exceptions

Comment 3 Adam Williamson 2019-03-25 21:30:04 UTC
The PR is now merged so I'm gonna mark this as ON_QA; we can check the next compose to see whether the images show up.

Comment 4 Adam Williamson 2019-03-26 15:23:27 UTC
Well, that problem does indeed appear to be solved now. However, now both image builds fail on two other package issues:

DEBUG util.py:554:  BUILDSTDERR: 2019-03-26 08:29:40,577: Problem 1: conflicting requests
DEBUG util.py:554:  BUILDSTDERR: 2019-03-26 08:29:40,577: - nothing provides oprofile >= 0.9.3 needed by eclipse-linuxtools-oprofile-7.1.0-3.fc30.noarch
DEBUG util.py:554:  BUILDSTDERR: 2019-03-26 08:29:40,578: Problem 2: conflicting requests
DEBUG util.py:554:  BUILDSTDERR: 2019-03-26 08:29:40,578: - nothing provides libreadline.so.7()(64bit) needed by ddd-3.3.12-30.fc29.x86_64.

Comment 5 Fedora Update System 2019-03-26 17:38:59 UTC
ddd-3.3.12-32.fc30 has been submitted as an update to Fedora 30. https://bodhi.fedoraproject.org/updates/FEDORA-2019-b3f3c01572

Comment 6 Adam Williamson 2019-03-26 17:43:51 UTC
I have sent a fixed ddd: https://bodhi.fedoraproject.org/updates/FEDORA-2019-b3f3c01572 . The oprofile dep is fixed by this eclipse-linuxtools update: https://bodhi.fedoraproject.org/updates/FEDORA-2019-e076afa6a2 , though it's fixed in a rather odd way (by keeping the oprofile subpackage but simply removing its dependency on oprofile, which doesn't seem to make a lot of sense) that I've asked the packager about.

I'll mark those updates both as related to this bug.

Comment 7 Fedora Update System 2019-03-26 17:48:15 UTC
apache-sshd-2.0.0-4.fc30 eclipse-4.11-2.fc30 eclipse-abrt-0.0.3-9.fc30 eclipse-dltk-5.11.0-1.fc30 eclipse-dtp-1.14.102-4.fc30 eclipse-egit-5.3.0-2.fc30 eclipse-egit-github-5.3.0-1.fc30 eclipse-epp-logging-2.0.7-8.fc30 eclipse-gef-3.11.0-9.fc30 eclipse-jgit-5.3.0-4.fc30 eclipse-launchbar-2.2.3-1.fc30 eclipse-license-2.0.1-7.fc30 eclipse-linuxtools-7.2.0-4.fc30 eclipse-m2e-core-1.11.0-1.fc30 eclipse-m2e-wtp-1.4.1-3.fc30 eclipse-mpc-1.7.5-2.fc30 eclipse-photran-9.2.1-3.fc30 eclipse-ptp-9.2.1-3.fc30 eclipse-pydev-7.1.0-2.fc30 eclipse-remote-3.0.1-2.fc30 eclipse-subclipse-4.3.0-0.3.git43b895a.fc30 eclipse-swtbot-2.8.0-3.fc30 eclipse-testng-6.14.3-2.fc30 eclipse-tm-terminal-4.5.100-1.fc30 eclipse-usage-4.11.0-1.fc30 eclipse-webtools-3.13.0-1.fc30 swt-chart-0.10.0-7.fc30 tycho-1.3.0-4.fc30 tycho-extras-1.3.0-2.fc30 has been submitted as an update to Fedora 30. https://bodhi.fedoraproject.org/updates/FEDORA-2019-e076afa6a2

Comment 8 Amit Saha 2019-03-26 23:26:33 UTC
Adam, thanks a lot.

Comment 9 Fedora Update System 2019-03-27 00:45:27 UTC
ddd-3.3.12-32.fc30 has been pushed to the Fedora 30 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2019-b3f3c01572

Comment 10 Fedora Update System 2019-03-29 19:15:01 UTC
apache-sshd-2.0.0-4.fc30, eclipse-4.11-2.fc30, eclipse-abrt-0.0.3-9.fc30, eclipse-dltk-5.11.0-1.fc30, eclipse-dtp-1.14.102-4.fc30, eclipse-egit-5.3.0-2.fc30, eclipse-egit-github-5.3.0-1.fc30, eclipse-epp-logging-2.0.7-8.fc30, eclipse-gef-3.11.0-9.fc30, eclipse-jgit-5.3.0-4.fc30, eclipse-launchbar-2.2.3-1.fc30, eclipse-license-2.0.1-7.fc30, eclipse-linuxtools-7.2.0-4.fc30, eclipse-m2e-core-1.11.0-1.fc30, eclipse-m2e-wtp-1.4.1-3.fc30, eclipse-mpc-1.7.5-2.fc30, eclipse-photran-9.2.1-3.fc30, eclipse-ptp-9.2.1-3.fc30, eclipse-pydev-7.1.0-2.fc30, eclipse-remote-3.0.1-2.fc30, eclipse-subclipse-4.3.0-0.3.git43b895a.fc30, eclipse-swtbot-2.8.0-3.fc30, eclipse-testng-6.14.3-2.fc30, eclipse-tm-terminal-4.5.100-1.fc30, eclipse-usage-4.11.0-1.fc30, eclipse-webtools-3.13.0-1.fc30, swt-chart-0.10.0-7.fc30, tycho-1.3.0-4.fc30, tycho-extras-1.3.0-2.fc30 has been pushed to the Fedora 30 stable repository. If problems still persist, please make note of it in this bug report.

Comment 11 Fedora Update System 2019-04-10 02:47:58 UTC
ddd-3.3.12-32.fc30 has been pushed to the Fedora 30 stable repository. If problems still persist, please make note of it in this bug report.