Bug 1694173

Summary: Some cluster operators never became available authentication during e2e run
Product: OpenShift Container Platform Reporter: Clayton Coleman <ccoleman>
Component: AuthAssignee: Sally <somalley>
Status: CLOSED ERRATA QA Contact: Chuan Yu <chuyu>
Severity: high Docs Contact:
Priority: unspecified    
Version: 4.1.0CC: aos-bugs, evb, nagrawal
Target Milestone: ---   
Target Release: 4.1.0   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2019-06-04 10:46:34 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description Clayton Coleman 2019-03-29 17:11:34 UTC
Authentication was available false after CVO reported success:

Mar 28 23:32:57.986: INFO: Operators still doing work: <nil>/authentication

https://openshift-gce-devel.appspot.com/build/origin-ci-test/logs/release-openshift-origin-installer-e2e-aws-4.0/6279

Comment 1 Sally 2019-04-08 15:02:30 UTC
I am aware that the authentication CO is the last to become available.  Looking into this, I see that cluster-authentication-operator is reporting Available=False and Failing=True when those should instead be Progressing=True.  Working up a PR for it.

Comment 3 Chuan Yu 2019-04-19 03:22:58 UTC
Verified.

$ oc get co authentication
NAME             VERSION                             AVAILABLE   PROGRESSING   FAILING   SINCE
authentication   4.1.0-0.nightly-2019-04-18-210657   True        False         False     59m

$ oc get clusterversion
NAME      VERSION                             AVAILABLE   PROGRESSING   SINCE   STATUS
version   4.1.0-0.nightly-2019-04-18-210657   True        False         56m     Cluster version is 4.1.0-0.nightly-2019-04-18-210657

Comment 5 errata-xmlrpc 2019-06-04 10:46:34 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2019:0758