Bug 1695091

Summary: When growing GPT partitions use [start of next - 1] instead of [start of next] as the new end sector.
Product: Red Hat Enterprise Linux 7 Reporter: Roman Bobek <rbobek>
Component: cloud-utils-growpartAssignee: Eduardo Otubo <eterrell>
Status: CLOSED ERRATA QA Contact: Yuxin Sun <yuxisun>
Severity: medium Docs Contact:
Priority: urgent    
Version: 7.6CC: eterrell, fkrska, mrezanin, mtessun, pierre, ribarry, thomas.oulevey, vhutsky, yacao, yujiang, yuxisun
Target Milestone: rcKeywords: ZStream
Target Release: ---   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: cloud-utils-growpart-0.29-5.el7 Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
: 1726564 (view as bug list) Environment:
Last Closed: 2019-08-06 13:18:47 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Bug Depends On:    
Bug Blocks: 1726564    
Attachments:
Description Flags
rpm package with the fix merged none

Description Roman Bobek 2019-04-02 13:06:08 UTC
Created attachment 1551006 [details]
rpm package with the fix merged

Hi all,

one of our customers ran into an issue when trying to resize a > 2TB disk with cloud-init/growpart.

There is already a report for this issue:
https://code.launchpad.net/~freddebacker/cloud-utils/cloud-utils/+merge/354305

Moreover the customer has provided us with the fixed rpm package (enclosed to this BZ.

Can we please merge this fix into the cloud-utils-growpart package shippped with RHEL 7?

Comment 19 errata-xmlrpc 2019-08-06 13:18:47 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2019:2340