Bug 1695446

Summary: The scroll bar always jumps back to the top on Safari browser
Product: OpenShift Container Platform Reporter: Jian Zhang <jiazha>
Component: Management ConsoleAssignee: Robb Hamilton <rhamilto>
Status: CLOSED CURRENTRELEASE QA Contact: Jian Zhang <jiazha>
Severity: high Docs Contact:
Priority: high    
Version: 4.1.0CC: aos-bugs, bandrade, chezhang, dyan, jfan, jokerman, mmccomas, pweil, scolange, spadgett, wsun, yapei, zitang
Target Milestone: ---Keywords: BetaBlocker
Target Release: 4.1.0   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2019-04-14 11:33:52 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description Jian Zhang 2019-04-03 06:39:55 UTC
Description of problem:
The drop down bar always jumps back to the top automatically on Safari browser,
it works well on Chrome, Firefox browser. It will lead to users cannot install the bottom operators what they want, such as etcd.

Version-Release number of selected component (if applicable):
Cluster version is 4.0.0-0.nightly-2019-04-02-081046
Console image: quay.io/openshift-release-dev/ocp-v4.0-art-dev@sha256:4d59f04482e59193f4120df4291481e46f52dfe997819d1c462b022a45d5fbd1
io.openshift.build.commit.id=59a5d768394658f83c876c7e3e00198213e77988

How reproducible:
always

Steps to Reproduce:
1. Install the OCP 4.0 with payload: 4.0.0-0.nightly-2019-04-02-081046
2. Open its UI by using the Safari browser.
3. "Catalog"->"OperatorHub"-> scroll to the bottom

Actual results:
The scroll bar will go back to the top automatically.

Expected results:
The scroll bar should stay the bottom of the page.


Additional info:

Comment 1 Samuel Padgett 2019-04-03 14:02:14 UTC
I have not been able to reproduce this. I left the page scrolled down for several minutes in Safari, and it never jumped back to the top.

Note that you might see some strange behavior in Safari in general due to bug 1686476 and HTTP/2 traffic being misdirected. If random network requests fail, it could manifest in strange ways. Are there any network errors or JavaScript errors in Safari developer tools when reproducing the problem? Can you wait a few minutes after logging in and refresh the page to test whether you still see the behavior?

Comment 2 Samuel Padgett 2019-04-03 15:36:44 UTC
This appears to be related to specific Safari versions. Version 12.0.3 (14606.4.5) doesn't exhibit the behavior. Version 12.1 (14607.1.40.1.4) does.

Comment 3 Robb Hamilton 2019-04-03 19:29:01 UTC
This is an upstream bug in PatternFly 4.  I've reported it at https://github.com/patternfly/patternfly-next/issues/1688.  Given where we are in the development cycle, we will have to fix this bug with overrides in the console code base.

Comment 4 Robb Hamilton 2019-04-04 19:34:16 UTC
PR to resolve: https://github.com/openshift/console/pull/1384

Comment 5 Jian Zhang 2019-04-08 05:52:55 UTC
Change Status to MODIFIED since no available payload. The fixed PR hasn't been merged in the latest payload:  Cluster version is 4.0.0-0.nightly-2019-04-05-165550
The latest image commit info:
             io.k8s.display-name=OpenShift Console
             io.openshift.build.commit.id=87cf25b49a98ef8d813c557ad4b74f0d18bc7d15
             io.openshift.build.commit.url=https://github.com/openshift/console/commit/87cf25b49a98ef8d813c557ad4b74f0d18bc7d15

Comment 6 Jian Zhang 2019-04-08 05:54:33 UTC
Samuel, Robb

Yes, thanks! My Safari version is Version 12.1 (13607.1.40.1.5).

Comment 11 Robb Hamilton 2019-04-10 17:09:46 UTC
The root cause of this bug is a regression introduced in Safari 12.1.  https://bugs.webkit.org/show_bug.cgi?id=196619

Comment 13 Jian Zhang 2019-04-12 03:13:34 UTC
LGTM, verify it.

Cluster version is 4.0.0-0.nightly-2019-04-10-182914
Console image info:  io.openshift.build.commit.id=931a16c5b12c0b55de33fbf5bc1728d5dfc59aac
Safari version is Version 12.1 (13607.1.40.1.5).