Bug 1695542

Summary: The page layout is ugly if login console on Edge browser
Product: OpenShift Container Platform Reporter: Yanping Zhang <yanpzhan>
Component: Management ConsoleAssignee: Samuel Padgett <spadgett>
Status: CLOSED CURRENTRELEASE QA Contact: Yadan Pei <yapei>
Severity: medium Docs Contact:
Priority: medium    
Version: 4.1.0CC: amobrem, aos-bugs, jokerman, mmccomas
Target Milestone: ---   
Target Release: 4.1.0   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2019-04-15 20:17:40 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Attachments:
Description Flags
consoleonedge none

Description Yanping Zhang 2019-04-03 10:14:34 UTC
Created attachment 1551310 [details]
consoleonedge

Description of problem:
When login console from Edge browser on win10, the page layout is ugly. Resources creation button is at the bottom of the page.

Version-Release number of selected component (if applicable):
Edge 40.15063.674.0
4.0.0-0.nightly-2019-04-02-150843
console image: quay.io/openshift-release-dev/ocp-v4.0-art-dev@sha256:4d59f04482e59193f4120df4291481e46f52dfe997819d1c462b022a45d5fbd1
io.openshift.build.commit.url=https://github.com/openshift/console/commit/59a5d768394658f83c876c7e3e00198213e77988

How reproducible:
Always

Steps to Reproduce:
1.Login console from Edge browser on win10, check each page.
2.
3.

Actual results:
1. The page layout is ugly. Resources creation button is at the bottom of the page.

Expected results:
1. The page layout should be normal as in other browsers.

Additional info:

Comment 1 Samuel Padgett 2019-04-03 13:09:45 UTC
We aren't able to reproduce on Edge 18 (44.17763.1.0) using OpenShift 4.0.0-0.alpha-2019-04-02-152430. It looks like the Edge version you are testing is old, Edge 15, which came out almost 2 years ago.

Edge 15 only has partial support for grid, which is required by Patternfly 4.

Comment 2 Samuel Padgett 2019-04-03 13:27:07 UTC
We'll need to support only Edge 16 or newer in OpenShift 4.x. Can you test with a newer Edge version? Edge 15 is almost two years old and does not support CSS grid template areas, which are required by Patternfly 4.

https://developer.mozilla.org/en-US/docs/Web/CSS/grid-template-areas

Ali, FYI. Let me know if you have concerns with that.

Comment 3 Yanping Zhang 2019-04-04 02:18:41 UTC
Thanks for feedback, I'll have a check once I get a newer Edge version.

Comment 4 Yanping Zhang 2019-04-08 03:00:49 UTC
Checked ocp 4.0 console on Edge 17(Edge 42.17134.1.0).
The console page works well now.