Bug 1696784

Summary: systemd 241 does not register bcache caching device
Product: [Fedora] Fedora Reporter: Matthias <keller1976>
Component: systemdAssignee: systemd-maint
Status: CLOSED ERRATA QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: unspecified Docs Contact:
Priority: unspecified    
Version: 30CC: awilliam, lnykryn, msekleta, robatino, ssahani, s, systemd-maint, tomek, zbyszek
Target Milestone: ---   
Target Release: ---   
Hardware: x86_64   
OS: Linux   
Whiteboard: RejectedBlocker AcceptedFreezeException
Fixed In Version: systemd-241-5.git3d835d0.fc30 Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2019-04-11 02:14:20 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
Bug Depends On:    
Bug Blocks: 1574716    

Description Matthias 2019-04-05 15:59:13 UTC
Description of problem:
systemd does not register the caching device of a bcache

Version-Release number of selected component (if applicable):
241 

tested not working with 4.gitcbf14c9.fc30 and ~rc2-1.fc30

works as expected with 10.git3bf819c.fc30

How reproducible:
Always

Steps to Reproduce:
1. Have a bcache installation and auto mount the bache device in fstab
2. Boot will hang because the bcache device cannot be found
3.

Actual results:
After removing the bcache from fstab I found that systemd 241 does not register the caching device (ssd) for bcache.

ls /sys/fs/bcache will only show "register" and "register_quiet" and no UUID of the caching device.

Expected results:
It should be registered in the same way as with systemd 239. systemd 239 works  in F29 and also F30 (have to downgrade the rpm's).

Additional info:

This discussion seems to be related: https://github.com/systemd/systemd/issues/11368

Comment 1 Tomasz Torcz 2019-04-07 09:19:08 UTC
The fix is queued for systemd-stable https://github.com/systemd/systemd-stable/pull/47. It would be great to have get it backported before F30 final.

Comment 2 Fedora Blocker Bugs Application 2019-04-07 09:23:10 UTC
Proposed as a Blocker for 30-final by Fedora user ttorcz using the blocker tracking app because:

 This breaks the criterion of "installed/upgraded system must boot".
The cause and fix is known, requires backporting patch to systemd.

Comment 3 Adam Williamson 2019-04-09 00:43:37 UTC
Discussed at 2019-04-08 blocker review meeting: https://meetbot-raw.fedoraproject.org/fedora-blocker-review/2019-04-08/ . Rejected as a blocker as there is no official bcache support in Fedora - e.g. the installer does not support it - so this cannot violate the upgrade criteria which relate to out-of-the-box configurations. However, accepted as a freeze exception issue as the impact on anyone who *has* manually set up bcache support is very significant and any fix for this should ideally be sent out during a freeze if it is otherwise safe.

Comment 4 Fedora Update System 2019-04-09 17:03:00 UTC
systemd-241-5.git3d835d0.fc30 has been submitted as an update to Fedora 30. https://bodhi.fedoraproject.org/updates/FEDORA-2019-3fa5db9e19

Comment 5 Fedora Update System 2019-04-10 14:38:05 UTC
systemd-241-5.git3d835d0.fc30 has been pushed to the Fedora 30 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2019-3fa5db9e19

Comment 6 Fedora Update System 2019-04-11 02:14:20 UTC
systemd-241-5.git3d835d0.fc30 has been pushed to the Fedora 30 stable repository. If problems still persist, please make note of it in this bug report.