Bug 1698270

Summary: flash-player-ppapi / chromium-pepper-flash not working on systemwide F30 PPAPI browsers
Product: [Fedora] Fedora Reporter: Sebastian <burni>
Component: chromiumAssignee: Tom "spot" Callaway <tcallawa>
Status: ASSIGNED --- QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: unspecified Docs Contact:
Priority: unspecified    
Version: 30CC: allanlewis99, tcallawa, tpopela, yaneti, zing
Target Milestone: ---   
Target Release: ---   
Hardware: x86_64   
OS: Unspecified   
Whiteboard:
Fixed In Version: Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Attachments:
Description Flags
The-not-allowed-sign1
none
a-puzzle-piece-2
none
this-is-how-a-working-flash-should-look-like none

Description Sebastian 2019-04-10 00:58:35 UTC
Created attachment 1554003 [details]
The-not-allowed-sign1

Description of problem:
libpepflashplayer.so is not loading on Fedora 30.

You can try any libpepflashplayer.so in any PPAPI browser (Chrome, Chromium, Opera, Vivaldi) and they all will fail.

Version-Release number of selected component (if applicable):
flash-player-ppapi-32.0.0.142-release.x86_64.rpm
chromium-pepper-flash-29.0.0.113-1.fc27.x86_64.rpm
chromium-pepper-flash-31.0.0.108-1.fc28.x86_64.rpm
chromium-pepper-flash-31.0.0.122-1.fc30.x86_64.rpm


How reproducible:
Upgrade from F28 or F29 with working flashplayer to F30.

Or boot up a Live-ISO of F30, enable the Adobe and/or russianfedora-repo, and install either of these packages or both of them: chromium-pepper-flash or flash-player-ppapi.

Open a flash website and allow Flash to be executed on the website settings.


Actual results:
A "not allowed / not available sign", i will provide an attachment image of this.

Expected results:
A working Flash in opera-stable, opera-developer, opera-beta, chromium, vivaldi-stable. As the same /home is used perfectly with working Flashplayer on all PPAPI-Browsers on my Fedora 29

Additional info:
As you know that an upgrade from F29 to F30 is not possible at the moment because of the superfamous accepted blocker-bug you have heard of for sure, i installed F28 and enabled flash and played my flashgame with F28. Then i upgraded that installation from there to F30. Flash broke immediately systemwide.

Comment 1 Sebastian 2019-04-10 01:01:53 UTC
Created attachment 1554004 [details]
a-puzzle-piece-2

Comment 2 Sebastian 2019-04-10 08:52:40 UTC
Created attachment 1554128 [details]
this-is-how-a-working-flash-should-look-like

Comment 3 Tom "spot" Callaway 2019-04-11 14:05:21 UTC
https://bugs.chromium.org/p/chromium/issues/detail?id=949312

Comment 4 Sebastian 2019-04-12 21:13:05 UTC
I can confirm! glibc 2.29 is the culprit!

Fortunately, i tested with a F29-live-ISO. Flash stopped working after dnf update glibc --releasever=30. Unfortunately, i tried to downgrade and failed. distro-sync glibc --releasever=29 broke the live-system and rendered it totally unusable. So, there is no temporary solution to my real F30 installation, i guess.

Should i report the issue upstream to the glibc-Developers or are they already aware of this?

Comment 5 Allan Lewis 2019-05-17 09:43:00 UTC
If I run `google-chrome-stable` from a terminal and try to load some Flash content, I see the following error:

    [17713:17713:0517/104100.346213:ERROR:buffer_manager.cc(488)] [.DisplayCompositor]GL ERROR :GL_INVALID_OPERATION : glBufferData: <- error from previous GL command

Comment 6 Allan Lewis 2019-06-10 11:18:37 UTC
On Fedora 30, this appears to have been fixed in glibc-2.29-15.fc30.x86_64.