Bug 1699688

Summary: Segfault enumerating OSS devices
Product: [Fedora] Fedora Reporter: Anton Oussik <antonoussik>
Component: mumbleAssignee: John <johnhatestrash>
Status: CLOSED ERRATA QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: unspecified Docs Contact:
Priority: unspecified    
Version: 30CC: bugzilla, carl, chkr, j.golderer, johnhatestrash, rdieter, sbroz
Target Milestone: ---   
Target Release: ---   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: mumble-1.2.19-14.fc30 mumble-1.2.19-14.fc29 Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2019-05-22 01:40:03 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Embargoed:

Description Anton Oussik 2019-04-15 00:13:39 UTC
Description of problem:

When mumble starts without a pre-existing configuration, or if the configuration window is opened, it tries enumerating OSS devices, and crashes.

Version-Release number of selected component (if applicable):

1.2.19

How reproducible:

Every time when opening configuration screen.

Steps to Reproduce:
1. Start Mumble
2. Go to Configure -> Settings in the menubar

Actual results:

Segfault

Expected results:

Settings window opens

Additional info:

A helpful person on Freenode's #mumble IRC channel suggested not compiling in OSS support, which can be done by adding "no-oss" option to the CONFIG flags in the %build section of the spec file.

Comment 1 Fedora Update System 2019-05-16 17:21:54 UTC
mumble-1.2.19-13.fc30 has been submitted as an update to Fedora 30. https://bodhi.fedoraproject.org/updates/FEDORA-2019-03f5772e40

Comment 2 Fedora Update System 2019-05-16 17:22:59 UTC
mumble-1.2.19-13.fc29 has been submitted as an update to Fedora 29. https://bodhi.fedoraproject.org/updates/FEDORA-2019-0f25c63522

Comment 3 Stepan Broz 2019-05-16 21:01:12 UTC
This update is a regression for me, upon first connect (reconnect right after application starts) a loud noise is heard (error), with the following in the client console:

[22:50] Unable to find matching CELT codecs with other clients. You will not be able to talk to all users.

Comment 4 Stepan Broz 2019-05-16 21:01:44 UTC
Sorry, forgot to mention, tested on Fedora 30.

Comment 5 Fedora Update System 2019-05-17 03:48:48 UTC
mumble-1.2.19-13.fc29 has been pushed to the Fedora 29 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2019-0f25c63522

Comment 6 Fedora Update System 2019-05-17 15:37:58 UTC
mumble-1.2.19-13.fc30 has been pushed to the Fedora 30 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2019-03f5772e40

Comment 7 Rex Dieter 2019-05-17 18:29:42 UTC
Please file a separate bug on the CELT thing, and when you mention regression, a regression from mumble-1.2.19-12.fc30 ?  (if so, that one wouldn't even start for me, how did it work for you?)

Comment 8 Rex Dieter 2019-05-17 18:56:42 UTC
*** Bug 1710114 has been marked as a duplicate of this bug. ***

Comment 9 Fedora Update System 2019-05-17 20:42:48 UTC
mumble-1.2.19-14.fc30 has been submitted as an update to Fedora 30. https://bodhi.fedoraproject.org/updates/FEDORA-2019-03f5772e40

Comment 10 Fedora Update System 2019-05-17 20:43:33 UTC
mumble-1.2.19-14.fc29 has been submitted as an update to Fedora 29. https://bodhi.fedoraproject.org/updates/FEDORA-2019-0f25c63522

Comment 11 Fedora Update System 2019-05-18 00:53:52 UTC
mumble-1.2.19-14.fc30 has been pushed to the Fedora 30 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2019-03f5772e40

Comment 12 Fedora Update System 2019-05-18 04:11:14 UTC
mumble-1.2.19-14.fc29 has been pushed to the Fedora 29 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2019-0f25c63522

Comment 13 Rex Dieter 2019-05-18 18:47:25 UTC
*** Bug 1711559 has been marked as a duplicate of this bug. ***

Comment 14 Fedora Update System 2019-05-22 01:40:03 UTC
mumble-1.2.19-14.fc30 has been pushed to the Fedora 30 stable repository. If problems still persist, please make note of it in this bug report.

Comment 15 Fedora Update System 2019-05-28 02:00:44 UTC
mumble-1.2.19-14.fc29 has been pushed to the Fedora 29 stable repository. If problems still persist, please make note of it in this bug report.