Bug 1700100

Summary: [marketplace] certified-operators causing e2e failures
Product: OpenShift Container Platform Reporter: Ian McLeod <imcleod>
Component: OLMAssignee: Aravindh Puthiyaparambil <aravindh>
OLM sub component: OperatorHub QA Contact: Fan Jia <jfan>
Status: CLOSED ERRATA Docs Contact:
Severity: high    
Priority: unspecified CC: aos-bugs, aravindh, bcook, eparis, jokerman, mmccomas, wking
Version: 4.1.0   
Target Milestone: ---   
Target Release: 4.2.0   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Cause: marketplace operator was scaling the registry deployment down and the scaling it back up to force updates. Consequence: This could cause the pod to crash loop if there was an issue in the registry pod. Fix: Don't scale it down and up, instead use an annotation to force the update. Result: The deployment won't become unavailable Note: This alone won't fix the bug. A fix to the e2e test that doesn't fail it on crash looping pods in the openshift-marketplace namespace is required
Story Points: ---
Clone Of: Environment:
Last Closed: 2019-10-16 06:28:05 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Bug Depends On:    
Bug Blocks: 1732588    

Comment 5 errata-xmlrpc 2019-10-16 06:28:05 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2019:2922