Bug 1701675

Summary: python-pytest-catchlog: Remove (sub)packages from Fedora 31+: python2-pytest-catchlog
Product: [Fedora] Fedora Reporter: Miro Hrončok <mhroncok>
Component: python-pytest-catchlogAssignee: Miro Hrončok <mhroncok>
Status: CLOSED RAWHIDE QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: unspecified Docs Contact:
Priority: unspecified    
Version: rawhideCC: cstratak, denis, igor.raits, mhroncok, ngompa13, pviktori, zbyszek
Target Milestone: ---   
Target Release: ---   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: python-pytest-catchlog-1.2.2-12.fc31 Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2019-04-27 13:59:29 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Bug Depends On:    
Bug Blocks: 1625773    

Description Miro Hrončok 2019-04-20 17:56:54 UTC
In line with the Mass Python 2 Package Removal [0], the following (sub)packages of python-pytest-catchlog were marked for removal:

 * python2-pytest-catchlog

According to our query, those (sub)packages only provide a Python 2 importable module. If this is not true, please tell us why, so we can fix our query.

Note that since Fedora 31, we also clean up pytest and/or linter plugins.

Please remove them from your package in Rawhide (Fedora 31).

Please don't do this for Fedora 30, consider the Final Freeze.

As said in the change document, if there is no objection in a week, we will remove the package(s) as soon as we get to it. This change might not match your packaging style, so we'd prefer if you did the change. If you need more time, please let us know here.

If you do the change yourself, it would help us a lot by reducing the amount of packages we need to mass change.

We hope this doesn't come to you as a surprise. If you want to know our motivation for this, please read the change document [0].

[0] https://fedoraproject.org/wiki/Changes/F31_Mass_Python_2_Package_Removal