Bug 1702657

Summary: reapply of MTU does not work
Product: Red Hat Enterprise Linux 7 Reporter: Thomas Haller <thaller>
Component: NetworkManagerAssignee: Beniamino Galvani <bgalvani>
Status: CLOSED ERRATA QA Contact: Desktop QE <desktop-qa-list>
Severity: medium Docs Contact:
Priority: medium    
Version: 7.7CC: atragler, bgalvani, edwardh, fgiudici, lrintel, rkhan, sukulkar, thaller, till, tpelka, vbenes
Target Milestone: rc   
Target Release: ---   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: NetworkManager-1.18.0-2.el7 Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2019-08-06 13:16:56 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
Bug Depends On:    
Bug Blocks: 1694958    

Description Thomas Haller 2019-04-24 11:36:36 UTC
Reapplying the MTU does (most of the time) not work:

  nmcli device modify "$DEVICE" ethernet.mtu $((1400 + RANDOM % 100))


I think this is due to https://cgit.freedesktop.org/NetworkManager/NetworkManager/tree/src/devices/nm-device.c?id=17adf58d5dc5d8253f2322e92b96bd176476b6f3#n9074 and https://cgit.freedesktop.org/NetworkManager/NetworkManager/commit/?id=2f8917237fdfb3e4da80989131cc1880013b9e92 (from 1.12.0)

Comment 7 Vladimir Benes 2019-05-17 08:08:19 UTC
MTU check added to @device_reapply_all test.
https://gitlab.freedesktop.org/NetworkManager/NetworkManager-ci/commit/ffc2d22df32cca9137bef4b224f653ca2a5ac9a4

Comment 9 errata-xmlrpc 2019-08-06 13:16:56 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2019:2302