Bug 1703558

Summary: [3.11] Provide statically linked client binary for Linux (non-portable libcrypto)
Product: OpenShift Container Platform Reporter: Eric Rich <erich>
Component: MasterAssignee: Michal Fojtik <mfojtik>
Status: CLOSED ERRATA QA Contact: Xingxing Xia <xxia>
Severity: high Docs Contact:
Priority: high    
Version: 3.11.0CC: aos-bugs, bmchugh, ccoleman, deparker, dvercill, eparis, erich, evb, fgiloux, fweimer, info-sistemi, jokerman, knewcomer, lxia, marioja76, mfojtik, mkhan, mmccomas, mnewsome, nagrawal, openshift-bugs-escalate, qe-baseos-tools-bugs, rsunog, smunilla, sperezto, tstellar, wking, wpinheir, wzheng
Target Milestone: ---Keywords: FutureFeature, Reopened
Target Release: 3.11.z   
Hardware: x86_64   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of: 1642158 Environment:
Last Closed: 2019-06-26 09:08:09 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Bug Depends On: 1642158    
Bug Blocks:    

Comment 1 Michal Fojtik 2019-04-29 08:26:35 UTC
PR: https://github.com/openshift/origin/pull/22694

Comment 8 Xingxing Xia 2019-06-12 06:27:29 UTC
Reproduced in old oc:
$ 3.11.110/oc get po 
3.11.110/oc: error while loading shared libraries: libcrypto.so.10: cannot open shared object file: No such file or directory

Verified in 3.11.117 oc with oc login/new-project/new-app/get/rsh.

Comment 10 errata-xmlrpc 2019-06-26 09:08:09 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2019:1605