Bug 1705283

Summary: F29 -> F30 (server): Problems with dovecot/auth against mariadb
Product: [Fedora] Fedora Reporter: Hendrik <mail>
Component: dovecotAssignee: Michal Hlavinka <mhlavink>
Status: CLOSED ERRATA QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: unspecified Docs Contact:
Priority: unspecified    
Version: 30CC: anon.amish, bennie.joubert, janfrode, mailinglists, mhlavink, mschmidt.mailbox, nberrehouc
Target Milestone: ---   
Target Release: ---   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: dovecot-2.3.6-3.fc30 dovecot-2.3.6-3.fc29 Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2019-06-14 00:53:44 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Description Hendrik 2019-05-01 22:14:54 UTC
Description of problem:

After upgrading Fedora server 29 to Fedora server 30 journalctl repeatedly reports errors in libmariadb.so.3:

May 01 -------- XXXXXXXX audit[3553]: ANOM_ABEND auid=4294967295 uid=0 gid=0 ses=4294967295 subj=system_u:system_r:dovecot_auth_t:s0 pid=3553 comm="auth" exe="/usr/libexec/dovecot/auth" sig=11 res=1
May 01 -------- XXXXXXXX kernel: traps: auth[3553] general protection fault ip:7f62a68b8308 sp:7ffe7e7f0640 error:0 in libmariadb.so.3[7f62a68ab000+26000]
May 01 -------- XXXXXXXX auth-worker: Fatal: master: service(auth-worker): child 3553 killed with signal 11 (core not dumped - https://dovecot.org/bugreport.html#coredumps - set set /proc/sys/fs/suid_dumpable to 2)

However, dovecot seems functional.


Version-Release number of selected component (if applicable):
Name         : dovecot
Epoch        : 1
Version      : 2.3.4
Release      : 2.fc30
Architecture : x86_64
Name         : mariadb-connector-c
Version      : 3.0.9
Release      : 2.fc30
Architecture : i686
Size         : 142 k

Name         : dovecot-mysql
Epoch        : 1
Version      : 2.3.4
Release      : 2.fc30
Architecture : x86_64
Size         : 31 k
Source       : dovecot-2.3.4-2.fc30.src.rpm
Repository   : @System



How reproducible:


Steps to Reproduce:
1. Mailserver running at F29 (dovecot with authentication against mariadb)
2. dnf system-upgrade --releasever=30 download

Comment 1 Marco Schmidt 2019-05-05 08:46:23 UTC
This issue has already been fixed in several distros, here is a link to the patch: https://github.com/dovecot/core/commit/3c5101ffdd2a8115e03ed7180d53578765dea4c9.patch

Not a problem of F30, problem existed in F29 too. I guess it was related to a MariaDB update early April. Getting auth-worker crashes since then but proper journal entries about those only after the upgrade from F29->F30.

Comment 2 Nicolas Berrehouc 2019-05-13 15:54:47 UTC
Same configuration and same problem.

Comment 3 Marco Schmidt 2019-05-16 19:15:32 UTC
Is it possible to switch to 2.3.6? The issue is fixed by now. We're still on 2.3.4 (F30), even F29 runs with 2.3.5.

Comment 4 Michal Hlavinka 2019-05-17 08:31:21 UTC
Dovecot can't be build with GCC9, https://dovecot.org/pipermail/dovecot/2019-January/114494.html upstream is already aware of this. Hopefully, next release will contain the fix.

Comment 5 Fedora Update System 2019-06-03 08:09:01 UTC
FEDORA-2019-9e004decea has been submitted as an update to Fedora 30. https://bodhi.fedoraproject.org/updates/FEDORA-2019-9e004decea

Comment 6 Fedora Update System 2019-06-03 08:09:06 UTC
FEDORA-2019-1b61a528dd has been submitted as an update to Fedora 29. https://bodhi.fedoraproject.org/updates/FEDORA-2019-1b61a528dd

Comment 7 Fedora Update System 2019-06-04 01:17:03 UTC
dovecot-2.3.6-3.fc30 has been pushed to the Fedora 30 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2019-9e004decea

Comment 8 Fedora Update System 2019-06-04 03:27:34 UTC
dovecot-2.3.6-3.fc29 has been pushed to the Fedora 29 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2019-1b61a528dd

Comment 9 Nicolas Berrehouc 2019-06-07 16:50:40 UTC
Since update, no more error in maillog.

Comment 10 Fedora Update System 2019-06-14 00:53:44 UTC
dovecot-2.3.6-3.fc30 has been pushed to the Fedora 30 stable repository. If problems still persist, please make note of it in this bug report.

Comment 11 Fedora Update System 2019-07-12 06:15:40 UTC
dovecot-2.3.6-3.fc29 has been pushed to the Fedora 29 stable repository. If problems still persist, please make note of it in this bug report.