Bug 1705429

Summary: Shift+Insert does not paste the text
Product: [Fedora] Fedora Reporter: Vyacheslav Boyko <mail4bvn>
Component: gnome-desktop3Assignee: Richard Hughes <rhughes>
Status: CLOSED DUPLICATE QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: unspecified Docs Contact:
Priority: unspecified    
Version: 30CC: dm.ilin, gnome-sig, olegon, rhughes, tiagomatos, vashirov
Target Milestone: ---   
Target Release: ---   
Hardware: x86_64   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2019-05-14 20:02:49 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description Vyacheslav Boyko 2019-05-02 09:34:04 UTC
Description of problem:

Shift+Insert does not paste text from clipboard at all. Neither in terminal, nor in any graphical application.

Version-Release number of selected component (if applicable):


How reproducible:
Always.

Steps to Reproduce:
1. Open browser (or any graphical application), select text and copy it into clipboard with Ctrl+Insert or Ctrl+C
2. Go to HTML Area or HTML Input block (or sublime text, or geany or something else) and try to paste the text has copied before with Shift+Insert
3. Nothing happens but window blinking.

Actual results:
Nothing happens


Expected results:
Text pasted.


Additional info:
Since update from Fedora 29 (Gnome 3) to Fedora 30 (Gnome 3). Does not work on XOrg and Wayland both.

Comment 1 tech 2019-05-07 10:56:04 UTC
Moreover, the Insert button does not work at all. Overtype mode not working, only blinking cursor.

Comment 2 olegon.ru 2019-05-08 04:49:11 UTC
The same trouble... Very important to me, because I using Shift-Ins more than 25 years...
Very strange bug, sometimes working after reboot short time, sometimes - no...

Comment 3 olegon.ru 2019-05-08 19:03:58 UTC
As I tested by xev, Insert key don't generate keypress event at all...

FocusOut event, serial 37, synthetic NO, window 0x3000001,
    mode NotifyGrab, detail NotifyAncestor

FocusIn event, serial 37, synthetic NO, window 0x3000001,
    mode NotifyUngrab, detail NotifyAncestor

KeymapNotify event, serial 37, synthetic NO, window 0x0,
    keys:  2   0   0   0   0   0   0   0   0   0   0   0   0   0   0   0   
           0   0   0   0   0   0   0   0   0   0   0   0   0   0   0   0

Comment 4 olegon.ru 2019-05-09 05:08:03 UTC
I choose "allow different sources for each window", remove all input sources and add again. English (US) first, Russian second. Reboot.
After reboot Insert disabled immediately, but I see "ru" in top bar and first focused window was in ru layout. When I open Region & Language, settings shows "Use the same source for all windows" again...
Hm... Strange, but now, while typing, I found, that English layout broken too, I see @ when press on " and vice versa. It's in Russian layout... I tried English (UK) without any success...

Comment 5 olegon.ru 2019-05-09 05:17:46 UTC
I removed Russian layout and reboot. Insert worked well until I add Russian layout and tried to switch to it.
Insert disabled in both layout.

Comment 6 olegon.ru 2019-05-09 17:26:46 UTC
Tried to change Russian layout to Russian (legacy) without any success... Tried to switch layout by Shift-Alt... :(

Comment 7 olegon.ru 2019-05-12 17:05:43 UTC
Alt-F2 - r make Insert working until switching to ru

Replaced Russian with French - problem not occured, but I need Russian :)

Tried Russian phonetic layout - problem exists

I have untouched (unused) F29 in VM, so upgraded it to F30 - no problem
Compared my PC dconf dump with VM dconf dump, saw the difference

[org/gnome/desktop/input-sources]
current=uint32 0

Added it to my dconf - problem exists

Disabled all extensions - without success

Remove all xorg.conf - without success

Installed imchooser - changed layout switcher without success

Change locale settings to en_US.UTF-8 - without success

Perform dnf autoremove (it killed my NetworkManager) - without success

removed all *m17n* packeges - without success

rpm -qf $(rpm -Va 2>&1 | grep -vE '^$|prelink:' | sed 's|.* /|/|') | sort -u | xargs dnf -y reinstall - without success

rpm -qa | xargs dnf -y reinstall - without success

dnf distro-sync
rpm -qaV > changes.txt
review changes.txt - without success

Found, that in Terminal works Shift-Win-Insert, wow! But that combination not work outside Terminal

Review all .rpmnew files - without success...

Cried 'I hate everybody' - without success...

Now I have VM without problem and my PC, I can't reinstall it because of too many software installed and configured, with this problem...

Comment 8 olegon.ru 2019-05-14 19:07:19 UTC
I found it.
dnf reinstall gsettings-desktop-schemas
disable default Win-Space in Keyboard shortcuts
reboot, Insert works!
enable Win-Space in Keyboard shortcuts
I won!

Comment 9 Viktor Ashirov 2019-05-14 20:02:49 UTC

*** This bug has been marked as a duplicate of bug 1697804 ***