Bug 1706438

Summary: python-hglib: Remove (sub)packages from Fedora 31+: python2-hglib
Product: [Fedora] Fedora Reporter: Miro Hrončok <mhroncok>
Component: python-hglibAssignee: Terje Røsten <terjeros>
Status: CLOSED RAWHIDE QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: unspecified Docs Contact:
Priority: unspecified    
Version: rawhideCC: cstratak, igor.raits, mhroncok, ngompa13, pviktori, terjeros, zbyszek
Target Milestone: ---   
Target Release: ---   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2019-05-05 12:00:32 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Bug Depends On:    
Bug Blocks: 1625773    

Description Miro Hrončok 2019-05-04 20:06:21 UTC
In line with the Mass Python 2 Package Removal [0], the following (sub)packages of python-hglib were marked for removal:

 * python2-hglib

According to our query, those (sub)packages only provide a Python 2 importable module. If this is not true, please tell us why, so we can fix our query.

Please remove them from your package in Rawhide (Fedora 31).

Please don't do this for Fedora 30, removing packages from a released Fedora branch is forbidden.

As said in the change document, if there is no objection in a week, we will remove the package(s) as soon as we get to it. This change might not match your packaging style, so we'd prefer if you did the change. If you need more time, please let us know here.

If you do the change yourself, it would help us a lot by reducing the amount of packages we need to mass change.

We hope this doesn't come to you as a surprise. If you want to know our motivation for this, please read the change document [0].

[0] https://fedoraproject.org/wiki/Changes/F31_Mass_Python_2_Package_Removal

Comment 1 Terje Røsten 2019-05-05 11:06:20 UTC
python2-hglib seems to be used by gofed:

$ dnf repoquery --whatrequires python2-hglib
Last metadata expiration check: 0:14:58 ago on sø. 05. mai 2019 kl. 12.48 +0200.
gofed-gofedlib-0:1.0.0-0.21.rc1.fc29.x86_64
gofed-infra-0:1.0.0-0.21.rc1.fc29.noarch
gofed-resources-0:1.0.0-0.21.rc1.fc29.noarch

Comment 2 Miro Hrončok 2019-05-05 11:36:50 UTC
Not on rawhide:

$ dnf repoquery --repo=rawhide{,-source} --whatrequires python2-hglib
(empty)

gofed was retired on rawhide.

Comment 3 Terje Røsten 2019-05-05 11:38:00 UTC
ok, great!

Comment 4 Terje Røsten 2019-05-05 12:00:19 UTC
Fixed:
 https://koji.fedoraproject.org/koji/buildinfo?buildID=1263096