Bug 1706689

Summary: Wrong apiserver for Copy Login Command
Product: OpenShift Container Platform Reporter: shahan <hasha>
Component: InstallerAssignee: W. Trevor King <wking>
Installer sub component: openshift-installer QA Contact: Johnny Liu <jialiu>
Status: CLOSED ERRATA Docs Contact:
Severity: medium    
Priority: unspecified CC: aos-bugs, chuyu, eparis, jokerman, mkhan, mmccomas, spadgett, vlaad, wking
Version: 4.1.0   
Target Milestone: ---   
Target Release: 4.1.0   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: Doc Type: No Doc Update
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2019-06-04 10:48:23 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Comment 1 Mo 2019-05-06 12:33:41 UTC
The installer team owns the infrastructures.config.openshift.io API.  Both the console and the OAuth server read its status.apiServerURL to tell users where the API server is.

Comment 2 Mo 2019-05-06 12:36:37 UTC
ex:

$ oc get infrastructures.config.openshift.io cluster -o jsonpath='{.status.apiServerURL}'
https://api-int.m044.devcluster.openshift.com:6443

Comment 3 W. Trevor King 2019-05-06 16:40:08 UTC
API groundwork in flight with [1].  After that gets kicked around and lands, we'll need to port the consumers to the appropriate internal/external property to fix this bug.

[1]: https://github.com/openshift/api/pull/308

Comment 4 Scott Dodson 2019-05-07 12:22:58 UTC
Installer needs to set the appropriate APIServerInternalURL value, no?

Comment 5 W. Trevor King 2019-05-07 13:19:08 UTC
[1] will set the new field.

[1]: https://github.com/openshift/installer/pull/1718

Comment 7 Samuel Padgett 2019-05-08 17:04:45 UTC
This needs an additional change: https://github.com/openshift/installer/pull/1727. Moving back to POST.

Comment 11 errata-xmlrpc 2019-06-04 10:48:23 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2019:0758