Bug 1706859

Summary: check_radius segfaults when tun interface is configured
Product: [Fedora] Fedora EPEL Reporter: Vít <vit>
Component: nagios-pluginsAssignee: Stephen John Smoogen <smooge>
Status: CLOSED ERRATA QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: medium Docs Contact:
Priority: unspecified    
Version: epel7CC: athmanem, b.heden, herrold, lemenkov, smooge, smooge, swilkerson
Target Milestone: ---   
Target Release: ---   
Hardware: Unspecified   
OS: Linux   
Whiteboard:
Fixed In Version: nagios-plugins-2.2.1-17.20190829gitfb792ff.el7 nagios-plugins-2.2.1-17.20190829gitfb792ff.el6 Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2019-09-14 00:40:40 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Attachments:
Description Flags
Patch to fix the issue none

Description Vít 2019-05-06 12:00:46 UTC
Created attachment 1564386 [details]
Patch to fix the issue

Description of problem:

When tun device is configured in the system, check_radius will crash (segmentation fault).


Version-Release number of selected component (if applicable): 2.2.1-16.20180725git3429dad


How reproducible: always


Steps to Reproduce:
1. ip tuntap add mode tun tun0
2. # /usr/lib64/nagios/plugins/check_radius -P 1812 -H localhost -F ./radiusclient.conf -u user -p XXXXXXXX


Actual results:
Segmentation fault (core dumped)


Expected results:
No crash.

Additional info:
The problem is caused by insufficent pointer validation in check_radius. The attached patch fixes this. I've already submitted  a pull request to get this included in upstream (https://github.com/nagios-plugins/nagios-plugins/pull/449).

Comment 1 Fedora Update System 2019-08-29 21:51:19 UTC
FEDORA-EPEL-2019-9b63c08c0f has been submitted as an update to Fedora EPEL 6. https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2019-9b63c08c0f

Comment 2 Fedora Update System 2019-08-29 22:04:14 UTC
FEDORA-EPEL-2019-22c97df420 has been submitted as an update to Fedora EPEL 7. https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2019-22c97df420

Comment 3 Fedora Update System 2019-08-30 16:07:45 UTC
nagios-plugins-2.2.1-17.20190829gitfb792ff.el7 has been pushed to the Fedora EPEL 7 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2019-22c97df420

Comment 4 Fedora Update System 2019-08-30 16:07:48 UTC
nagios-plugins-2.2.1-17.20190829gitfb792ff.el6 has been pushed to the Fedora EPEL 6 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2019-9b63c08c0f

Comment 5 Fedora Update System 2019-09-14 00:40:40 UTC
nagios-plugins-2.2.1-17.20190829gitfb792ff.el7 has been pushed to the Fedora EPEL 7 stable repository. If problems still persist, please make note of it in this bug report.

Comment 6 Fedora Update System 2019-09-14 04:05:19 UTC
nagios-plugins-2.2.1-17.20190829gitfb792ff.el6 has been pushed to the Fedora EPEL 6 stable repository. If problems still persist, please make note of it in this bug report.