Bug 1708956

Summary: Text in menus and many UI elements are missing
Product: [Fedora] Fedora Reporter: bztdlinux
Component: cura-lulzbotAssignee: Tom "spot" Callaway <tcallawa>
Status: CLOSED ERRATA QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: unspecified Docs Contact:
Priority: unspecified    
Version: 30CC: mhroncok, tcallawa, zaitcev
Target Milestone: ---   
Target Release: ---   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: cura-lulzbot-3.6.8-1.fc30 Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2019-05-29 00:49:17 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Attachments:
Description Flags
Prepare view none

Description bztdlinux 2019-05-11 23:10:19 UTC
Created attachment 1567386 [details]
Prepare view

Description of problem:
Most of the UI fields are missing their text, and the tree menus for configuring printing options are missing entirely.

Version-Release number of selected component (if applicable):
3.6.8
This happened after upgrading to Fedora 30.

Comment 1 bztdlinux 2019-05-11 23:12:43 UTC
Note it's not just the text being invisible, but that most of the text is replaced with empty strings, save for a few random ones in menus. It almost feels like a localization related issue (my locale is en-US)

Comment 2 Miro Hrončok 2019-05-12 00:03:34 UTC
Assigned to Tom. I won't be able to look into this any time soon and he takes care of this package more than I do. He is aware of the issue, but I don't know if he found the cause yet.

Comment 3 bztdlinux 2019-05-14 00:10:06 UTC
This console output seems suspicious:

2019-05-13 17:08:43,234 - WARNING - [(139771599750784)-MainThread] UM.Qt.QtApplication.__onQmlWarning [274]: file:///usr/share/cura-lulzbot/resources/qml/SidebarHeader.qml:138: TypeError: Property 'i18nc' of object i18nCatalogProxy(0x55d0d423e750) is not a function

repeated x1000 times

Comment 4 Miro Hrončok 2019-05-14 04:49:45 UTC
*** Bug 1709512 has been marked as a duplicate of this bug. ***

Comment 5 Tom "spot" Callaway 2019-05-14 13:48:14 UTC
Fix building now. qt5.12 needs function calls to be parenthesis wrapped, and they were not for functions in uranium, including i18nc, which handles all of the internationalized strings. Hence, they never rendered. Found fix in upstream uranium, easy to backport, confirmed locally on my F30 install.

Comment 6 Fedora Update System 2019-05-14 13:55:39 UTC
CuraEngine-lulzbot-3.6.8-1.fc30 cura-lulzbot-3.6.8-1.fc30 lulzbot-marlin-firmware-1.1.9.34-5.fc30 python-uranium-lulzbot-3.6.8-2.fc30 has been submitted as an update to Fedora 30. https://bodhi.fedoraproject.org/updates/FEDORA-2019-f4800a5be1

Comment 7 Fedora Update System 2019-05-14 13:55:46 UTC
CuraEngine-lulzbot-3.6.8-1.fc30 cura-lulzbot-3.6.8-1.fc30 lulzbot-marlin-firmware-1.1.9.34-5.fc30 python-uranium-lulzbot-3.6.8-2.fc30 has been submitted as an update to Fedora 30. https://bodhi.fedoraproject.org/updates/FEDORA-2019-f4800a5be1

Comment 8 Pete Zaitcev 2019-05-14 14:59:37 UTC
This did not work for me - menus are still empty of text:

dnf upgrade --enablerepo=updates-testing --advisory=FEDORA-2019-f4800a5be1

[zaitcev@hermeneutic-one tmp]$ rpm -qa | grep lulzbot
python3-uranium-lulzbot-3.6.8-1.fc30.noarch
cura-lulzbot-3.6.8-1.fc30.noarch
lulzbot-marlin-firmware-1.1.9.34-5.fc30.noarch
lulzbot-marlin-firmware-pro-2.0.0.110-5.fc30.noarch
CuraEngine-lulzbot-3.6.8-1.fc30.x86_64
[zaitcev@hermeneutic-one tmp]$ 

Not sure if I need to derail the update though.

Comment 9 Tom "spot" Callaway 2019-05-14 15:12:20 UTC
(In reply to Pete Zaitcev from comment #8)
> This did not work for me - menus are still empty of text:
> 
> dnf upgrade --enablerepo=updates-testing --advisory=FEDORA-2019-f4800a5be1
> 
> [zaitcev@hermeneutic-one tmp]$ rpm -qa | grep lulzbot
> python3-uranium-lulzbot-3.6.8-1.fc30.noarch

You need python3-uranium-lulzbot-3.6.8-2.fc30. That has the fix and just got added to the update. I don't think the update has regenerated in bodhi yet.
Here's the koji link: https://koji.fedoraproject.org/koji/buildinfo?buildID=1267527

Comment 10 bztdlinux 2019-05-14 23:39:44 UTC
Thanks for the quick fix! I installed just the uranium package from koji and it fixed the problem for me.

Comment 11 Fedora Update System 2019-05-15 00:52:55 UTC
CuraEngine-lulzbot-3.6.8-1.fc30, cura-lulzbot-3.6.8-1.fc30, lulzbot-marlin-firmware-1.1.9.34-5.fc30, python-uranium-lulzbot-3.6.8-2.fc30 has been pushed to the Fedora 30 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2019-f4800a5be1

Comment 12 Fedora Update System 2019-05-29 00:49:17 UTC
CuraEngine-lulzbot-3.6.8-1.fc30, cura-lulzbot-3.6.8-1.fc30, lulzbot-marlin-firmware-1.1.9.34-5.fc30, python-uranium-lulzbot-3.6.8-2.fc30 has been pushed to the Fedora 30 stable repository. If problems still persist, please make note of it in this bug report.