Bug 170931

Summary: gnome-help crashes on startup
Product: [Fedora] Fedora Reporter: Gregory Leblanc <gleblanc>
Component: yelpAssignee: Matthew Barnes <mbarnes>
Status: CLOSED CURRENTRELEASE QA Contact:
Severity: high Docs Contact:
Priority: medium    
Version: rawhideCC: caillon
Target Milestone: ---   
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: 2.15.1-1 Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2006-05-15 14:54:11 EDT Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Attachments:
Description Flags
gdb output none

Description Gregory Leblanc 2005-10-15 21:53:22 EDT
Description of problem:
Gnome-help crashes when trying to open help from GNOME applications, or when
started from the command line

Version-Release number of selected component (if applicable):
yelp-2.12.1-1

How reproducible:
always

I'll attach a trace to this bug.
Comment 1 Gregory Leblanc 2005-10-15 21:53:23 EDT
Created attachment 120030 [details]
gdb output
Comment 2 Gregory Leblanc 2005-10-15 23:22:37 EDT
Hrm, ok, looks like this was mozilla related.  I used to have

Sep 28 18:26:51 Updated: mozilla.i386 37:1.7.12-1.5.1

but rawhide now contains 
Oct 15 19:20:41 Installed: mozilla.i386 37:1.7.11-5

Forcing a downgrade seems to have fixed yelp.  I'm not sure if further
investigation is warranted or not.
Comment 3 Ray Strode [halfline] 2005-10-16 18:30:25 EDT
yelp has to be built against the version of mozilla installed on the machine...
It's a little odd though, that you needed to downgrade.

Chris, did mozilla get downgraded without bumping epoch in rawhide?
Comment 5 Matthew Barnes 2006-05-15 14:54:11 EDT
This issue appears to be fixed in the latest rawhide.

yelp-2.15.1-1
mozilla-1.7.13-1.1.fc5