Bug 1709566

Summary: Mistral-db-manager Attribute errors
Product: Red Hat OpenStack Reporter: Sai Sindhur Malleni <smalleni>
Component: openstack-mistralAssignee: Adriano Petrich <apetrich>
Status: CLOSED ERRATA QA Contact: nlevinki <nlevinki>
Severity: low Docs Contact:
Priority: low    
Version: 15.0 (Stein)CC: apetrich, beth.white, jjoyce, jschluet, michele, slinaber, tvignaud
Target Milestone: rcKeywords: Triaged
Target Release: 15.0 (Stein)   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: openstack-mistral-8.0.1-0.20190724130443.19ddb05.el8ost Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2019-09-21 11:21:58 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description Sai Sindhur Malleni 2019-05-13 20:23:24 UTC
Description of problem: Seeing several attribute errors in mistral-db-manage logs
2019-05-13 18:14:01.854 13 ERROR mistral.actions.openstack.action_generator.base [-] Failed to create action: nova.certs_get: AttributeError: 'Client' object has no attribute 'certs'
2019-05-13 18:14:01.854 13 ERROR mistral.actions.openstack.action_generator.base Traceback (most recent call last):
2019-05-13 18:14:01.854 13 ERROR mistral.actions.openstack.action_generator.base   File "/usr/lib/python3.6/site-packages/mistral/actions/openstack/action_generator/base.py", line 143, in create_actions
2019-05-13 18:14:01.854 13 ERROR mistral.actions.openstack.action_generator.base     client_method = class_.get_fake_client_method()
2019-05-13 18:14:01.854 13 ERROR mistral.actions.openstack.action_generator.base   File "/usr/lib/python3.6/site-packages/mistral/actions/openstack/base.py", line 75, in get_fake_client_method
2019-05-13 18:14:01.854 13 ERROR mistral.actions.openstack.action_generator.base     return cls._get_client_method(cls._get_fake_client())
2019-05-13 18:14:01.854 13 ERROR mistral.actions.openstack.action_generator.base   File "/usr/lib/python3.6/site-packages/mistral/actions/openstack/base.py", line 59, in _get_client_method
2019-05-13 18:14:01.854 13 ERROR mistral.actions.openstack.action_generator.base     attribute = getattr(attribute, attr)
2019-05-13 18:14:01.854 13 ERROR mistral.actions.openstack.action_generator.base AttributeError: 'Client' object has no attribute 'certs'
==============================================================================

2019-05-13 18:14:06.930 13 ERROR mistral.actions.openstack.action_generator.base [-] Failed to create action: vitrage.rca_get: AttributeError: 'NoneType' object has no attribute 'Client'
2019-05-13 18:14:06.930 13 ERROR mistral.actions.openstack.action_generator.base Traceback (most recent call last):
2019-05-13 18:14:06.930 13 ERROR mistral.actions.openstack.action_generator.base   File "/usr/lib/python3.6/site-packages/mistral/actions/openstack/action_generator/base.py", line 143, in create_actions
2019-05-13 18:14:06.930 13 ERROR mistral.actions.openstack.action_generator.base     client_method = class_.get_fake_client_method()
2019-05-13 18:14:06.930 13 ERROR mistral.actions.openstack.action_generator.base   File "/usr/lib/python3.6/site-packages/mistral/actions/openstack/base.py", line 75, in get_fake_client_method
2019-05-13 18:14:06.930 13 ERROR mistral.actions.openstack.action_generator.base     return cls._get_client_method(cls._get_fake_client())
2019-05-13 18:14:06.930 13 ERROR mistral.actions.openstack.action_generator.base   File "/usr/lib/python3.6/site-packages/mistral/actions/openstack/actions.py", line 947, in _get_fake_client
2019-05-13 18:14:06.930 13 ERROR mistral.actions.openstack.action_generator.base     return cls._get_client_class()()
2019-05-13 18:14:06.930 13 ERROR mistral.actions.openstack.action_generator.base   File "/usr/lib/python3.6/site-packages/mistral/actions/openstack/actions.py", line 925, in _get_client_class
2019-05-13 18:14:06.930 13 ERROR mistral.actions.openstack.action_generator.base     return vitrageclient.Client
2019-05-13 18:14:06.930 13 ERROR mistral.actions.openstack.action_generator.base AttributeError: 'NoneType' object has no attribute 'Client'
===============================================================================
2019-05-13 18:14:07.047 13 ERROR mistral.actions.openstack.action_generator.base [-] Failed to create action: qinling.webhooks_delete: AttributeError: 'NoneType' object has no attribute 'Client'
2019-05-13 18:14:07.047 13 ERROR mistral.actions.openstack.action_generator.base Traceback (most recent call last):
2019-05-13 18:14:07.047 13 ERROR mistral.actions.openstack.action_generator.base   File "/usr/lib/python3.6/site-packages/mistral/actions/openstack/action_generator/base.py", line 143, in create_actions
2019-05-13 18:14:07.047 13 ERROR mistral.actions.openstack.action_generator.base     client_method = class_.get_fake_client_method()
2019-05-13 18:14:07.047 13 ERROR mistral.actions.openstack.action_generator.base   File "/usr/lib/python3.6/site-packages/mistral/actions/openstack/base.py", line 75, in get_fake_client_method
2019-05-13 18:14:07.047 13 ERROR mistral.actions.openstack.action_generator.base     return cls._get_client_method(cls._get_fake_client())
2019-05-13 18:14:07.047 13 ERROR mistral.actions.openstack.action_generator.base   File "/usr/lib/python3.6/site-packages/mistral/actions/openstack/actions.py", line 1000, in _get_fake_client
2019-05-13 18:14:07.047 13 ERROR mistral.actions.openstack.action_generator.base     return cls._get_client_class()(
2019-05-13 18:14:07.047 13 ERROR mistral.actions.openstack.action_generator.base   File "/usr/lib/python3.6/site-packages/mistral/actions/openstack/actions.py", line 988, in _get_client_class
2019-05-13 18:14:07.047 13 ERROR mistral.actions.openstack.action_generator.base     return qinlingclient.Client
2019-05-13 18:14:07.047 13 ERROR mistral.actions.openstack.action_generator.base AttributeError: 'NoneType' object has no attribute 'Client'



Version-Release number of selected component (if applicable):
OSP15

How reproducible:
100%

Steps to Reproduce:
1. Deploy UC
2. Try to deploy OC
3.

Actual results:
Errors in logs

Expected results:
No errors

Additional info:

Comment 1 Adriano Petrich 2019-05-16 13:56:14 UTC
There are two aspects to this error. One is that nova doesn't have the property/methods "cert" anymore. they were removed in pike 18 months ago

https://github.com/openstack/python-novaclient/commit/4bc4078fcb4f2a47269882cc83e1d637db1f37c2 I will remove them from mistral also

the other aspect is that we are not using the other and the error on registering clients that we don't use generate a bit of mess on the logs but they are innocuous and can be ignored.

I'm submitting a patch for the nova errors.

Comment 9 errata-xmlrpc 2019-09-21 11:21:58 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2019:2811