Bug 1709754

Summary: Unable to install condor package due to missing dependency libboost_python.so.1.66.0()(64bit)
Product: [Fedora] Fedora Reporter: Roderick Johnstone <rmj>
Component: condorAssignee: Tim Theisen <tim>
Status: CLOSED ERRATA QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: unspecified Docs Contact:
Priority: unspecified    
Version: 30CC: bbockelm, bcotton, eerlands, guigo.lourenco, matt, matyas, steve.traylen, tim, tstclair, valtri
Target Milestone: ---   
Target Release: ---   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: condor-8.8.4-1.fc29 Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2019-08-10 06:31:08 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description Roderick Johnstone 2019-05-14 09:16:10 UTC
Description of problem:
Unable to install condor due to missing dependency.


Version-Release number of selected component (if applicable):
8.6.11-3.fc29

How reproducible:
Every time.

Steps to Reproduce:
1. dnf install condor
2.
3.

Actual results:
Last metadata expiration check: 0:06:13 ago on Tue 14 May 2019 10:03:58 BST.
Error: 
 Problem: conflicting requests
  - nothing provides libboost_python.so.1.66.0()(64bit) needed by condor-8.6.11-3.fc29.x86_64
(try to add '--skip-broken' to skip uninstallable packages)


Expected results:
Successful install of condor package.

Additional info:

Comment 1 Ben Cotton 2019-05-14 15:36:05 UTC
Looks like this is because the package hasn't rebuilt against the newer boost. The build error is deep enough into the build system that I'm not entirely sure how to diagnose it. Passing it to the uppstream folks.


Build error:
Scanning dependencies of target gahp_server
[ 99%] Building CXX object src/gt2_gahp/CMakeFiles/gahp_server.dir/gahp_server.cpp.o
[ 99%] Building CXX object src/gt2_gahp/CMakeFiles/gahp_server.dir/my_ez.cpp.o
[ 99%] Building CXX object src/gt2_gahp/CMakeFiles/gahp_server.dir/__/condor_utils/condor_version.cpp.o
[ 99%] Linking CXX executable gahp_server
/usr/bin/ld: CMakeFiles/gahp_server.dir/gahp_server.cpp.o: undefined reference to symbol 'dlopen@@GLIBC_2.2.5'
/usr/bin/ld: /usr/lib/gcc/x86_64-redhat-linux/9/../../../../lib64/libdl.so: error adding symbols: DSO missing from command line
collect2: error: ld returned 1 exit status
make[2]: *** [src/gt2_gahp/CMakeFiles/gahp_server.dir/build.make:143: src/gt2_gahp/gahp_server] Error 1
make[1]: *** [CMakeFiles/Makefile2:6000: src/gt2_gahp/CMakeFiles/gahp_server.dir/all] Error 2
make: *** [Makefile:152: all] Error 2

Comment 2 Fedora Update System 2019-07-31 01:57:47 UTC
FEDORA-2019-f0f74bf64a has been submitted as an update to Fedora 29. https://bodhi.fedoraproject.org/updates/FEDORA-2019-f0f74bf64a

Comment 3 Fedora Update System 2019-08-01 05:33:37 UTC
condor-8.8.4-1.fc29 has been pushed to the Fedora 29 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2019-f0f74bf64a

Comment 4 Fedora Update System 2019-08-10 06:31:08 UTC
condor-8.8.4-1.fc29 has been pushed to the Fedora 29 stable repository. If problems still persist, please make note of it in this bug report.

Comment 5 Tim Theisen 2019-10-23 11:49:06 UTC
Hi Ben,

I believe that the upgrade to 8.8.4 fixed this problem. Let me know if this is not the case for you.

...Tim