Bug 1709852

Summary: New tabs show up as empty after rendering and window decorations become unresponsive with firefox-wayland
Product: [Fedora] Fedora Reporter: Hans de Goede <hdegoede>
Component: firefoxAssignee: Gecko Maintainer <gecko-bugs-nobody>
Status: CLOSED WORKSFORME QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: unspecified Docs Contact:
Priority: unspecified    
Version: rawhideCC: 0xalen+redhat, anto.trande, baker1tex, fedora, gecko-bugs-nobody, jan.public, jhorak, john.j5live, kengert, pjasicek, rhughes, rstrode, sandmann, stransky, yaneti
Target Milestone: ---Keywords: Reopened
Target Release: ---   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2019-07-11 13:17:15 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Bug Depends On:    
Bug Blocks: 1054334    

Description Hans de Goede 2019-05-14 12:22:56 UTC
When running firefox-wayland (1) sometimes (2) new tabs stop rendering, they are clearly loading (spinner is shown on the tab) and I do believe they do actually render, but the final blit of the rendered result to the tab does not happen.

When I tear the tab away from the firefox-window, so that it becomes a new-window then it does instantly show, showing that it has fully loaded (and rendered) but just is not shown.

When this happens the minimize, maximize and close buttons on the affected firefox window also stop working (I'm using CSD). This is a per window thing, new tabs in other firefox windows work fine, the min/max/close buttons on other windows also work fine.

When this happens I'm seeing various messages about IPC problems in my journal, 
as such I think this may be related to bug 1585332, note firefox does not crash for me.

1) I think this is firefox-wayland only
2) Seems to happen mostly when having one or more tabs with youtube open

Comment 1 Christian Stadelmann 2019-05-14 20:33:01 UTC
(In reply to Hans de Goede from comment #0)
> When running firefox-wayland (1) sometimes (2) new tabs stop rendering, they
> are clearly loading (spinner is shown on the tab) and I do believe they do
> actually render, but the final blit of the rendered result to the tab does
> not happen.

I'm seeing this too. Note that once the first new tab has stopped rendering, no new tab in old windows can render any more. This issue has been present for a while (at least before 66.0.2), but I don't know how old it really is.

Comment 2 Hans de Goede 2019-06-05 16:04:37 UTC
This seems to no longer be happening with the 67.0 release, closing.

Comment 3 Hans de Goede 2019-06-06 08:13:30 UTC
(In reply to Hans de Goede from comment #2)
> This seems to no longer be happening with the 67.0 release, closing.

I celebrated too soon, I did not see this for about a week, but it just happened again, re-opening.

One new thing which I did learn is that I can still click on elements of the non visible page and then I get taken to other parts of the site. So everything seems to be working fine, except that the contents is not visible.

Comment 4 Hans de Goede 2019-07-11 13:17:15 UTC
I've not seen this since that 1 time this triggered again on 6-6, so lets close this again.

Comment 5 Phil Baker 2019-08-23 22:55:34 UTC
Not fixed... I'm still experiencing this bug on Fedora 30 (Workstation Edition) with Firefox on Wayland 68.0.2

Firefox on Wayland works for a while, then suddenly new tabs are rendered blank (just a solid sheet of white). Also, when the blank tabs appear and all rendering in other tabs stop. Clicking on the "hamburger menu" in the upper right results in nothing appearing. 

Restarting Firefox on Wayland fixes the issue temporarily, all tabs render again, the hamburger menu works, until an indeterminate amount of time passes, then the blank window rendering bug appears again. 

Hardware: Lenovo ThinkPad T560, Intel GPU, 3K screen scaled at 2x. Running default GNOME session on Wayland.

Comment 6 Martin Stransky 2019-08-24 07:14:59 UTC
Can you please try latest mozilla nightly? how-to is here:
https://fedoraproject.org/wiki/How_to_debug_Firefox_problems?rd=Bug_info_Firefox#Testing_Mozilla_binaries

Also disable webrender at nightly (at about:config) as it's default for nightly now.

Comment 7 Phil Baker 2019-10-23 12:07:10 UTC
Firefox on Wayland has improved since my last post in August. I am currently on Firefox 69.0.3 on Fedora 30.

The only remaining regression relative to Firefox on Xwayland is the toolbar dropdown menus (such as Bookmarks) fail to appear after clicking, but eventually do appear once the cursor is moved off the toolbar into the browser content window.

I have a second Fedora 30 system (Intel NUC) that I will test and post what I find here.

Comment 8 Phil Baker 2019-10-23 12:33:44 UTC
I downloaded the FF 71 nightly and ran it on my ThinkPad, via the terminal command:

MOZ_ENABLE_WAYLAND=1 ./firefox -ProfileManager -no-remote'  

I did not notice the issues with the drop down toolbar menus described in Comment 7. Everything worked as it should.

Comment 9 Martin Stransky 2019-10-23 12:59:26 UTC
Can you please also try Firefox 70 from koji? - https://koji.fedoraproject.org/koji/packageinfo?packageID=37

Comment 10 Phil Baker 2019-10-23 14:04:05 UTC
I just installed the Firefox 70.0-1 & Firefox Wayland 70-0.1 RPMs from Koji and it works perfectly. Dropdown menus appear immediately upon clicking toolbar bookmarks and hamburger icons. Thumbs up here.