Bug 1711475

Summary: soas arm fails to start
Product: [Fedora] Fedora Reporter: satellitgo
Component: arm-boot-configAssignee: Brendan Conoboy <blc>
Status: CLOSED RAWHIDE QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: unspecified Docs Contact:
Priority: unspecified    
Version: 30CC: blc, dennis, pbrobinson, satellitgo
Target Milestone: ---   
Target Release: ---   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2019-05-27 12:59:03 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description satellitgo 2019-05-17 22:05:35 UTC
Description of problem:
soas arm fails to start
 the initramfs is host-only
Version-Release number of selected component (if applicable):


How reproducible:


Steails to bootps to Reproduce:
1.
2.
3.

Actual results:
fails to boot

Expected results:
boot
see:https://wiki.sugarlabs.org/go/Fedora_30#not_working

Additional info:
"<pwhalen> satellit, seeing the same issue. it looks like the initramfs is host-only for some reason. Looking at the kickstart I think I see why. <pwhalen> we remove dracut-config-generic in post, but it looks like we also rebuild the initramfs for sugar as well..seems like the rebuild happens after we remove dracut-config-generic.. so host only :(

<pwhalen> satellit, broken in rawhide as well - 15M May 14 15:59 initramfs-5.1.0-1.fc31.armv7hl.img <pwhalen> should be around 40-50M" "<pwhalen> satellit, if you replace the initramfs with this one - https://fedorapeople.org/~pwhalen/soas/initramfs-5.0.9-301.fc30.armv7hl.img <pwhalen> it will boot. Thanks for bringing this to our attention."

    may 15:

<pwhalen> satellit, mount the sd, the look for the partition labelled boot

<pwhalen> might be easiest to then right click and open in terminal, then 'su -c "wget https://fedorapeople.org/~pwhalen/soas/initramfs-5.0.9-301.fc30.armv7hl.img"' <pwhalen> then 'sudo mv initramfs-5.0.9-301.fc30.armv7hl.img.1 initramfs-5.0.9-301.fc30.armv7hl.img' <pwhalen> should od it <pwhalen> or do it even <pwhalen> and we'll get it fixed for f31. As it is it will only work in qemu.

Comment 1 satellitgo 2019-05-20 21:57:46 UTC
works 

satellit@localhost ~]$ cd /run/media/satellit/__boot/
[satellit@localhost __boot]$ su
Password: 
[root@localhost __boot]# chmod 777 initramfs-5.0.9-301.fc30.armv7hl.img
[root@localhost __boot]# rm initramfs-5.0.9-301.fc30.armv7hl.img
rm: remove regular file 'initramfs-5.0.9-301.fc30.armv7hl.img'? y
[root@localhost __boot]# cp /home/satellit/Downloads/f30/initramfs-5.0.9-301.fc30.armv7hl.img /run/media/satellit/__boot/initramfs-5.0.9-301.fc30.armv7hl.img 
[root@localhost __boot]# ls
config-5.0.9-301.fc30.armv7hl  grub2
dtb                            initramfs-5.0.9-301.fc30.armv7hl.img
dtb-5.0.9-301.fc30.armv7hl     lost+found
efi                            olpc_build
extlinux                       System.map-5.0.9-301.fc30.armv7hl
grub                           vmlinuz-5.0.9-301.fc30.armv7hl
[root@localhost __boot]#

Comment 2 satellitgo 2019-05-20 21:59:58 UTC
satellit@localhost ~]$ cd /run/media/satellit/__boot/
[satellit@localhost __boot]$ su
Password: 
[root@localhost __boot]# chmod 777 initramfs-5.0.9-301.fc30.armv7hl.img
[root@localhost __boot]# rm initramfs-5.0.9-301.fc30.armv7hl.img
rm: remove regular file 'initramfs-5.0.9-301.fc30.armv7hl.img'? y
[root@localhost __boot]# cp /home/satellit/Downloads/f30/initramfs-5.0.9-301.fc30.armv7hl.img /run/media/satellit/__boot/initramfs-5.0.9-301.fc30.armv7hl.img 


works

Comment 3 Peter Robinson 2019-06-19 10:24:07 UTC
This is now fixed in rawhide