Bug 171312

Summary: dhclient-script runs chkconfig with bad args when ypbind is not installed
Product: [Fedora] Fedora Reporter: Kenneth Ahn Jensen <kaj>
Component: dhcpAssignee: Jason Vas Dias <jvdias>
Status: CLOSED CURRENTRELEASE QA Contact:
Severity: medium Docs Contact:
Priority: medium    
Version: 4   
Target Milestone: ---   
Target Release: ---   
Hardware: i386   
OS: Linux   
Whiteboard:
Fixed In Version: FC5 Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2006-09-21 22:14:26 EDT Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Description Kenneth Ahn Jensen 2005-10-20 13:47:32 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 6.0; X11; Linux i686) Opera 7.54  [en]

Description of problem:
When the ypbind (and yptools) packages are not installed, the dhclient-script 
causes an error message, due to running "chkconfig --level=$level ypbind" in 3 
different places.
This causes error messages in the startup screen and when running /etc/init.d/
network, /sbin/ifup and other things.

When the ypbind and yptools packages are installed the errors go away.

Version-Release number of selected component (if applicable):
dhclient-3.0.2-24.FC4 ypbind-1.17.2-5

How reproducible:
Always

Steps to Reproduce:
1. yum install dhclient ypbind
2. make eth0 configurable via dhcp
3. /etc/init.d/network restart

  

Actual Results:  root@adm2-56 ~]# service network restart
Shutting down interface eth0:  chkconfig version 1.3.20 - Copyright (C) 1997-2000 
Red Hat, Inc.
This may be freely redistributed under the terms of the GNU Public License.

usage:   chkconfig --list [name]
         chkconfig --add <name>
         chkconfig --del <name>
         chkconfig [--level <levels>] <name> <on|off|reset>
                                                           [  OK  ]
Shutting down loopback interface:                          [  OK  ]
Bringing up loopback interface:                            [  OK  ]
Bringing up interface eth0:
Determining IP information for eth0...chkconfig version 1.3.20 - Copyright (C) 
1997-2000 Red Hat, Inc.
This may be freely redistributed under the terms of the GNU Public License.

usage:   chkconfig --list [name]
         chkconfig --add <name>
         chkconfig --del <name>
         chkconfig [--level <levels>] <name> <on|off|reset>
 done.
                                                           [  OK  ]
[root@adm2-56 ~]#

Expected Results:  [root@adm2-56 ~]# service network restart
Shutting down interface eth0:                              [  OK  ]
Shutting down loopback interface:                          [  OK  ]
Bringing up loopback interface:                            [  OK  ]
Bringing up interface eth0:
Determining IP information for eth0... done.
                                                           [  OK  ]
[root@adm2-56 ~]#

Additional info:

Recently upgraded from FC3 to FC4 using yum update, but all rpms seem to be at 
the correct versions.
Comment 1 Jason Vas Dias 2005-10-20 13:51:16 EDT
*** Bug 171313 has been marked as a duplicate of this bug. ***
Comment 2 Jason Vas Dias 2005-10-20 14:11:37 EDT
Oops, I guess dhclient was never tested without the ypbind package being 
installed and with dhcp servers supplying the nis-servers option.

This bug is not due to any change in the dhclient-3.0.2-24.FC4 version -
it has always been in every FC-4 dhclient version.

If your dhcp server is supplying the nis-servers option, which is the only
way this dhclient-script code can be reached, you should probably consider 
installing ypbind .

This bug has no effect other than causing the annoying chkconfig usage
messages to be generated. 

It is arguably a chkconfig bug that only the '--level=' option emits a
usage message for a nonexistent script - all other chkconfig invocations
emit message like:
# chkconfig --list nil
  'error reading information on service nil: No such file or directory'
but
# chkconfig --level=0 nil
produces the full Usage: message.

I should have appended '>/dev/null 2>&1' to the chkconfig commands - will do
so in next version. 

Meanwhile, you can workaround by:
  # echo '# chkconfig - 80 80
  # description: not installed
'> /etc/init.d/ypbind


Even though you have not installed ypbind, I believe dhclient-script should
still update the ypbind configuration, so that if/when ypbind gets installed, 
it can pick up a valid configuration; also other software might make use of
this configuration.
Comment 3 Fedora Update System 2005-11-21 13:59:43 EST
From User-Agent: XML-RPC

dhcp-3.0.2-26.FC4 has been pushed for FC4, which should resolve this issue.  If these problems are still present in this version, then please make note of it in this bug report.
Comment 4 Fedora Update System 2005-12-14 15:32:48 EST
From User-Agent: XML-RPC

dhcp-3.0.2-26.FC4 has been pushed for FC4, which should resolve this issue.  If these problems are still present in this version, then please make note of it in this bug report.
Comment 5 Bill Nottingham 2006-09-21 22:14:26 EDT
Closing bugs in MODIFIED state from prior Fedora releases. If this bug persists
in a current Fedora release (such as Fedora Core 5 or later), please reopen and
set the version appropriately.