Bug 171313

Summary: dhclient-script runs chkconfig with bad args when ypbind is not installed
Product: [Fedora] Fedora Reporter: Kenneth Ahn Jensen <kaj>
Component: dhcpAssignee: Jason Vas Dias <jvdias>
Status: CLOSED DUPLICATE QA Contact:
Severity: medium Docs Contact:
Priority: medium    
Version: 4   
Target Milestone: ---   
Target Release: ---   
Hardware: i386   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2005-10-20 13:51:04 EDT Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:

Description Kenneth Ahn Jensen 2005-10-20 13:47:45 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 6.0; X11; Linux i686) Opera 7.54  [en]

Description of problem:
When the ypbind (and yptools) packages are not installed, the dhclient-script 
causes an error message, due to running "chkconfig --level=$level ypbind" in 3 
different places.
This causes error messages in the startup screen and when running /etc/init.d/
network, /sbin/ifup and other things.

When the ypbind and yptools packages are installed the errors go away.

Version-Release number of selected component (if applicable):
dhclient-3.0.2-24.FC4 ypbind-1.17.2-5

How reproducible:
Always

Steps to Reproduce:
1. yum install dhclient ypbind
2. make eth0 configurable via dhcp
3. /etc/init.d/network restart

  

Actual Results:  root@adm2-56 ~]# service network restart
Shutting down interface eth0:  chkconfig version 1.3.20 - Copyright (C) 1997-2000 
Red Hat, Inc.
This may be freely redistributed under the terms of the GNU Public License.

usage:   chkconfig --list [name]
         chkconfig --add <name>
         chkconfig --del <name>
         chkconfig [--level <levels>] <name> <on|off|reset>
                                                           [  OK  ]
Shutting down loopback interface:                          [  OK  ]
Bringing up loopback interface:                            [  OK  ]
Bringing up interface eth0:
Determining IP information for eth0...chkconfig version 1.3.20 - Copyright (C) 
1997-2000 Red Hat, Inc.
This may be freely redistributed under the terms of the GNU Public License.

usage:   chkconfig --list [name]
         chkconfig --add <name>
         chkconfig --del <name>
         chkconfig [--level <levels>] <name> <on|off|reset>
 done.
                                                           [  OK  ]
[root@adm2-56 ~]#

Expected Results:  [root@adm2-56 ~]# service network restart
Shutting down interface eth0:                              [  OK  ]
Shutting down loopback interface:                          [  OK  ]
Bringing up loopback interface:                            [  OK  ]
Bringing up interface eth0:
Determining IP information for eth0... done.
                                                           [  OK  ]
[root@adm2-56 ~]#

Additional info:

Recently upgraded from FC3 to FC4 using yum update, but all rpms seem to be at 
the correct versions.
Comment 1 Kenneth Ahn Jensen 2005-10-20 13:49:36 EDT
Aaargh, my impatience made me I press the submit button twice. Just delete this 
bug, it's the same as 171312.
Comment 2 Jason Vas Dias 2005-10-20 13:51:04 EDT

*** This bug has been marked as a duplicate of 171312 ***